1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Om651 not starting

Discussion in 'Engine, Drivetrain, Fuel and Exhaust' started by Kev555, Jan 15, 2019.

  1. Kev555

    Kev555 Senior Member

    Messages:
    101
    Likes Received:
    16
    Joined:
    Dec 31, 2017
    Location:
    Omagh NI
    Your Mercedes:
    2011 vito 113 CDI OM651 W639 panel van
    Hi i have a 2011 113 vito with om651 engine. I was driving one day and it started filling the road with white smoke. i pulled over and the van stopped and wouldnt start again. i replaced the injectors i suspected were the problem and it still wont start. i have an icarsoft i980 fault code reader and it shows no codes
     
  2. Wighty

    Wighty Senior Member

    Messages:
    5,193
    Likes Received:
    2,433
    Joined:
    Aug 4, 2016
    Location:
    Sunny Essex
    Your Mercedes:
    W211/E320cdi/2009 and CLK200k 2009
    Do the new injectors need coding to the engine with MB Star computer ?
     
    moj91 likes this.
  3. bembo449

    bembo449 Senior Member

    Messages:
    2,716
    Likes Received:
    493
    Joined:
    Jan 2, 2012
    Location:
    lincolnshire
    Your Mercedes:
    216 5.5 v8 , range rover vogue , 221 320cdi , alfa romeo brera
    bit of a stab in the dark , doing injectors without any codes to prove they are faulty
     
  4. mrmb

    mrmb Senior Member

    Messages:
    133
    Likes Received:
    51
    Joined:
    May 9, 2018
    Location:
    Galway
    Your Mercedes:
    W204 C200 CDI Sport Edition 125 2011 / W215 CL600 Bi-Turbo M275 2002
    You have to code the new injectors.
     
  5. Steve@Avantgarde

    Steve@Avantgarde Forum Supporter Authorised Forum Supporter

    Messages:
    6,674
    Likes Received:
    839
    Joined:
    Dec 8, 2009
    Location:
    Bristol/Somerset
    Your Mercedes:
    Mercedes-Benz C32AMG, SL55AMG, C320CDI Sport Edition Estate and SLR McLaren Coupe Roadster.
    Umm, what made you guess at the injectors?

    Do you have any fuel pressure? I would check that if I were you, before you do anything else.
     
    Kev555 likes this.
  6. OP
    Kev555

    Kev555 Senior Member

    Messages:
    101
    Likes Received:
    16
    Joined:
    Dec 31, 2017
    Location:
    Omagh NI
    Your Mercedes:
    2011 vito 113 CDI OM651 W639 panel van
    Thanks for replies, this is a bit long winded but better to give all info so everybody sees what a nightmare ive had already. The van had issues since i bought it last year. I saw it was in the early stages of black death on two cylinders when trying to diagnose an intermittant miss and limp mode on cylinder 3 about 3 months after private purchase(yes i got a lemon) so being a mechanic years ago before most of the modern computer whizz kid engines were introduced and purchasing a basic diagnostic reader i gave it a go . Injector 3 was seized so had to get it pulled out by a specialist, i recut the seats and new washers and bolts and got a second hand injector with the same part number. i also realised injector 2 had the wrong part number from the rest as well so i knew i got a lemon and somebody else had been butchering around the van before me. bought another injector and got info that injectors are mostly plug and play and if any issues then can be programmed to suit the vehicle. van ran fine with replacement injectors but i still had that intermittant miss and limp mode occasionally on cylinder 3. I was planning to get them reprogrammed but had a trip from house just before christmas and broke down on way home as above post. thought it was an injector blown once i got the van home. turned the van over a few times and lifted injectors out and number 4 injector which was original was soaking wet on the tip and the rest were dry. so left them all in to be reconditioned and thats were im at now. I am beginning to think that the fuel might be dodgey but i always buy it in the one place all the time and no issues.
     
    Last edited: Jan 16, 2019
  7. OP
    Kev555

    Kev555 Senior Member

    Messages:
    101
    Likes Received:
    16
    Joined:
    Dec 31, 2017
    Location:
    Omagh NI
    Your Mercedes:
    2011 vito 113 CDI OM651 W639 panel van
    Hi Bembo as you see above injectors were a bit of a mixed bag so i wanted to get them done anyways if i ironed out the rest of the teething problems first and you see what way that went lol
     
  8. OP
    Kev555

    Kev555 Senior Member

    Messages:
    101
    Likes Received:
    16
    Joined:
    Dec 31, 2017
    Location:
    Omagh NI
    Your Mercedes:
    2011 vito 113 CDI OM651 W639 panel van
    Hi mrmb and Wighty i prob should but would it at least start if they werent coded?. if not its a bit of a bother towing to get injectors reprogrammed at local diesel specialist
     
  9. OP
    Kev555

    Kev555 Senior Member

    Messages:
    101
    Likes Received:
    16
    Joined:
    Dec 31, 2017
    Location:
    Omagh NI
    Your Mercedes:
    2011 vito 113 CDI OM651 W639 panel van
    Steve I have 1 bar pressure when ignition on and 3 bar when cranking engine iirc, Does this sound right? Everything i checked on the scanner last night all seem to be working as they should but im not up on what the value of the sensors should be if i got that correct?
     
    Last edited: Jan 16, 2019
  10. OP
    Kev555

    Kev555 Senior Member

    Messages:
    101
    Likes Received:
    16
    Joined:
    Dec 31, 2017
    Location:
    Omagh NI
    Your Mercedes:
    2011 vito 113 CDI OM651 W639 panel van
    Im going to drain tank towards weekend to rule out dodgey diesel as i cant understand why the van is so nearly running and no fault codes. forgot to add it did run for about 3 seconds last night at one point on all 4 cylinders but engine was very muted if anybody has come across this before
     
  11. Uncle Benz

    Uncle Benz Senior Member

    Messages:
    2,348
    Likes Received:
    495
    Joined:
    Mar 31, 2006
    Location:
    West Sussex
    Your Mercedes:
    Mainly Mercedes
    My experience with petrol contamination in om651 is that even with a tiny bit of petrol in the tank they become a proper bastard to start. Also the piezo injectors cannot be successfully reconditioned, or so I have been told. Mercedes supply exchange injectors, but they are new units when you get them.
     
    Kev555 likes this.
  12. OP
    Kev555

    Kev555 Senior Member

    Messages:
    101
    Likes Received:
    16
    Joined:
    Dec 31, 2017
    Location:
    Omagh NI
    Your Mercedes:
    2011 vito 113 CDI OM651 W639 panel van
    Hi uncle benz im sure your right as i didnt ask were they my same old ones back. the guy i deal with is a professional bosh siemens delphi agent. Thats good to know about the petrol. will know better after drain and new filter
     
  13. OP
    Kev555

    Kev555 Senior Member

    Messages:
    101
    Likes Received:
    16
    Joined:
    Dec 31, 2017
    Location:
    Omagh NI
    Your Mercedes:
    2011 vito 113 CDI OM651 W639 panel van
    Dont want to throw to much info into the arena but just going to put codes up was getting before van broke down in case it sheds any light on my problem with cylinder 3 in case it crops up again if i get the van started.
    The main code that always popped up was "Teach in of the operating parameters for cylinder 3 has a malfunction"
    this one popped up a few times as well "The flow in the exhaust gas recirculation (cylinder bank 1) has a malfunction"
     
    Last edited: Jan 16, 2019
  14. Uncle Benz

    Uncle Benz Senior Member

    Messages:
    2,348
    Likes Received:
    495
    Joined:
    Mar 31, 2006
    Location:
    West Sussex
    Your Mercedes:
    Mainly Mercedes
    Ah! If the egr is stuck open it'll be trying to run on its own exhaust. This gives the symptoms you describe. Seen it on om642 loads of times

    Also, 3 bar cranking seems low. Will need 250+ to start, but the code reader you have may be inaccurate in that regard. Some of them are strange. My snap on machine says some ridiculous things sometimes
     
    Last edited: Jan 16, 2019
    Kev555 likes this.
  15. OP
    Kev555

    Kev555 Senior Member

    Messages:
    101
    Likes Received:
    16
    Joined:
    Dec 31, 2017
    Location:
    Omagh NI
    Your Mercedes:
    2011 vito 113 CDI OM651 W639 panel van
    I take it uncle benz your refering to the the second code i posted and not the two? Would that have been the reason it broke down as well? I will check fuel pressures again tomorrow eve but according to the scanner theres 274.000 miles on the van but not what i see looking at the dash lol
     
  16. Uncle Benz

    Uncle Benz Senior Member

    Messages:
    2,348
    Likes Received:
    495
    Joined:
    Mar 31, 2006
    Location:
    West Sussex
    Your Mercedes:
    Mainly Mercedes
    Yes, egr is exhaust gas recirculation. It allows exhaust gas into the intake manifold at certain times to reduce nox emissions. If it sticks open the engine will bog down and often stall.
     
  17. OP
    Kev555

    Kev555 Senior Member

    Messages:
    101
    Likes Received:
    16
    Joined:
    Dec 31, 2017
    Location:
    Omagh NI
    Your Mercedes:
    2011 vito 113 CDI OM651 W639 panel van
    just seein your edit now has refreshed my memory fuel pressure was 300 i seen when cranking. sorry about mistake
     
    Last edited: Jan 16, 2019
  18. Uncle Benz

    Uncle Benz Senior Member

    Messages:
    2,348
    Likes Received:
    495
    Joined:
    Mar 31, 2006
    Location:
    West Sussex
    Your Mercedes:
    Mainly Mercedes
    Stored mileage is always kilometres.
     
    Taffy7hfa likes this.
  19. OP
    Kev555

    Kev555 Senior Member

    Messages:
    101
    Likes Received:
    16
    Joined:
    Dec 31, 2017
    Location:
    Omagh NI
    Your Mercedes:
    2011 vito 113 CDI OM651 W639 panel van
    Just to clarify uncle benz, could you say this is why the van is not starting at the minute and would this have any relevance to the miss on number 3 cylinder
     
    Last edited: Jan 16, 2019
  20. OP
    Kev555

    Kev555 Senior Member

    Messages:
    101
    Likes Received:
    16
    Joined:
    Dec 31, 2017
    Location:
    Omagh NI
    Your Mercedes:
    2011 vito 113 CDI OM651 W639 panel van
    I was wondering as scanner was quoting miles, just checking then theres only a discrepency of 20,000 miles from my clock. maybe not as much of a lemon as i thought but its still a lemon :)
     

Share This Page