Overheating problem C180/W202

mercisbest

Member
Joined
Oct 20, 2008
Messages
15
Reaction score
0
I have a 1995 c180/w202,

The problem I have is my merc is overheating, I replaced the thermostat last month and recently serviced it.
The temp increase quickly from cold start, and when I stop the water pipes attached to the radiator are solid with pressure.
I have checked the water pump and that seems is working fine, also there is no sign of any white gunk.

I have checked for all the pipes and radiator for any leaks, all of which are fine.

Can anybody help me with this problem.

Cheers
 

xitrum_dalat

Member
Joined
Dec 16, 2008
Messages
20
Reaction score
0
check for electric fan. is it still work step 1 when open air con

and step 2 when red hot

some time fuse of electic fan is loossen


another to check is fan clutch in front of engine
 

Cosworth

Active Senior Members
Joined
Jul 11, 2007
Messages
347
Reaction score
0
Is the rad getting cold all over or just in parts.

Have you removed the pump and inspected?
 
OP
M

mercisbest

Member
Joined
Oct 20, 2008
Messages
15
Reaction score
0
  • Thread Starter
  • Thread starter
  • #4
Alright mate,

The radiator is hot all over, and no have'nt taken the pump out to inspect it, but you can see that the water is getting pump around the engine.
 

Cosworth

Active Senior Members
Joined
Jul 11, 2007
Messages
347
Reaction score
0
Alright mate,

The radiator is hot all over, and no have'nt taken the pump out to inspect it, but you can see that the water is getting pump around the engine.

sometimes the propeller snaps inside and stops circulation of water and also how is your fan, viscous fan, does it move freely or tight.
 
OP
M

mercisbest

Member
Joined
Oct 20, 2008
Messages
15
Reaction score
0
  • Thread Starter
  • Thread starter
  • #6
Alright mate,

It sounds like I will need to change the pump, and the fan coupling, as it making a grinding noise, here's hoping this will solve my problem.

Apperciate the help.

Cheers.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
The other thing here is to check that it is not the head gasket gone, and the system is being pressurized, do not forget that the water does not circulate until the thermostat has opened around 87c
 


Prestige Motor Group is Hertfordshire's Premier INDEPENDENT MERCEDES BENZ SPECIALIST. We offer a service exceeding Main dealership expectations and HUGE savings on Main Dealership Prices. WE BEAT ANY GENUINE QUOTE! Prestige Motor Group pride ourselves on delivering excellent customer service as we believe the customer and the Car deserve the best.
Tel: 01462 672458www.prestigemotorsofhertfordshire.co.uk/
Top Bottom