1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

R230 rad fan not working

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by consort, Dec 21, 2012.

  1. consort

    consort Active Member

    Messages:
    40
    Likes Received:
    0
    Joined:
    Mar 18, 2010
    Location:
    East Malling Kent
    Your Mercedes:
    Punto Grand Evo Esssee, ML300, TVR 4.5 Cerbera
    The radiator fan is not running and consequently causing the engine to run hot on my SL 500 R230.

    The fan runs when the a/c is on and so I would imagine that the water temp sender unit is at fault.

    Would anyone on here be able to enlighten me?

    Out of interest, but I am sure not connected, but my heater control instrument cluster sometimes dims, and I have no hot air coming out of the screen vents.


    Thanks for any advice.
     
  2. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    310
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    This could be damp in the near side SAM if the fan cannot be found, I will take a look at the wiring diagrams later in the day.
     
  3. Alex Crow

    Alex Crow Senior Member

    Messages:
    10,677
    Likes Received:
    33
    Joined:
    Jul 9, 2009
    Location:
    Super Suffolk
    Your Mercedes:
    W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
    How hot does it get?

    Is it only a problem when stationary/moving very slowly?
     
  4. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    310
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    You have relay K25 and f49
     
  5. OP
    consort

    consort Active Member

    Messages:
    40
    Likes Received:
    0
    Joined:
    Mar 18, 2010
    Location:
    East Malling Kent
    Your Mercedes:
    Punto Grand Evo Esssee, ML300, TVR 4.5 Cerbera
    The car always runs at 80 degrees. Now creams up to just below 100 when stationary. I am still getting some rad cooling by the fan when the a.c is on to cool the condenser. No a.c then the rad fan does not run.
     
  6. OP
    consort

    consort Active Member

    Messages:
    40
    Likes Received:
    0
    Joined:
    Mar 18, 2010
    Location:
    East Malling Kent
    Your Mercedes:
    Punto Grand Evo Esssee, ML300, TVR 4.5 Cerbera
    Thanks, I will check today. They are located within the engine compartment in the nearside fuse box I assume?
     
  7. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    310
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    I think that is correct :D 1 day we may get a car where the actual fan has packed up, not in your case as it does run
     
  8. Gkinghorn

    Gkinghorn Senior Member

    Messages:
    2,808
    Likes Received:
    178
    Joined:
    Jul 25, 2009
    Location:
    Bournemouth
    Your Mercedes:
    E350 CDI Cabriolet - 2011
    I worry when mine crawls up to just below 90 when stationary in traffic on a hot day (to be expected) 100 would really bother me ..but yes x80 is about normal in m view..
     
  9. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    310
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    100c is a very efficient temp for the engine, my 1928RR would have hardly any power under 100c
     
  10. reflexboy

    reflexboy Senior Member

    Messages:
    536
    Likes Received:
    1
    Joined:
    Jul 11, 2004
    Location:
    Surrey
    Your Mercedes:
    E350CDi Sport&R172 SLK250CDi AMG Sport
    On a cold day mine will sit at a needle's width over 80. In traffic it will be about 90 and I can hear the fan cutting in and out OK. Driving on a warm day it will be about 85ish. Sitting on the motorway it will be just over 80
     
  11. OP
    consort

    consort Active Member

    Messages:
    40
    Likes Received:
    0
    Joined:
    Mar 18, 2010
    Location:
    East Malling Kent
    Your Mercedes:
    Punto Grand Evo Esssee, ML300, TVR 4.5 Cerbera
    Yes throughout 7 years of ownership, (never owned a car for so long) it has always been spot on 80 even in the heat of summer.
     
  12. OP
    consort

    consort Active Member

    Messages:
    40
    Likes Received:
    0
    Joined:
    Mar 18, 2010
    Location:
    East Malling Kent
    Your Mercedes:
    Punto Grand Evo Esssee, ML300, TVR 4.5 Cerbera
    sorted

    Many thanks. I tracked the problem down to a faulty water sender. £8.95 on e bay for a new one. All fixed and nice and cool.
     

Share This Page