S Class w140 heater booster fan stopped working

380560

Senior Member
Joined
Jul 22, 2008
Messages
144
Reaction score
0
Location
Isle of Skye Highlands
Your Mercedes
S Class, W140 4.2 Limo, Nissan 300ZX twin turbo, Porsche 911.
The booster has stopped working, I have checked the fuses under the bonnet and all are OK, I have pressed all heater control buttons and temp controls and still nothing. I recently removed and replaced the radio would/ could that effected anything? Can anyone help please??
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Some are not worth saving and it helps others to keep the W140 alive.

jib

True and makes them worth more,, What a shame that only 1 off, 140 estate was ever made
 

jibcl500

Senior Member
Joined
Oct 22, 2005
Messages
6,420
Reaction score
6
Age
53
Location
Cambridgeshire
Your Mercedes
CL500,ML55,SLK280

Attachments

  • image_03.jpg
    image_03.jpg
    52.4 KB · Views: 27
  • image_01.jpg
    image_01.jpg
    52 KB · Views: 31
  • image_02.jpg
    image_02.jpg
    49 KB · Views: 27
  • mercedes-benz-s-class-station wagon-2006-62.jpg
    mercedes-benz-s-class-station wagon-2006-62.jpg
    63.9 KB · Views: 28

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
See attached.

jib

Very nice,,only one firm made the official conversion, and that was BINZ were allowed to do official conversions,,yes there were others that did the conversions,,there was a nice feature in the MB Classic mag.

I would buy something like the one in your picture,,so nice
 
Last edited:

jibcl500

Senior Member
Joined
Oct 22, 2005
Messages
6,420
Reaction score
6
Age
53
Location
Cambridgeshire
Your Mercedes
CL500,ML55,SLK280
The black on is a S73 V12 with the Coupe front end conversion, well its not a conversion becuase the Coupe and Saloon W140 front ends can be swapped.

jib
 
OP
3

380560

Senior Member
Joined
Jul 22, 2008
Messages
144
Reaction score
0
Location
Isle of Skye Highlands
Your Mercedes
S Class, W140 4.2 Limo, Nissan 300ZX twin turbo, Porsche 911.
  • Thread Starter
  • Thread starter
  • #10
Sclass w140 booster problem

thanks to you all................so it could be the brushes which are worn, where are they and are they easy to to get to. I see you have advised 251 are these the brushes and is the number on the attached the MB part number?
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
251 is the actual motor,, I may be able to print off the instructions for getting it out.

Ou can get brushes from tool shops etc that repair small electric hand tools

I will post back
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
40
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
heater motor is easy to get at, there is a thread with exactly the same issues running at the moment, i suggest you search for it.
 
OP
3

380560

Senior Member
Joined
Jul 22, 2008
Messages
144
Reaction score
0
Location
Isle of Skye Highlands
Your Mercedes
S Class, W140 4.2 Limo, Nissan 300ZX twin turbo, Porsche 911.
  • Thread Starter
  • Thread starter
  • #13
thanks guys I must say you are all really helpful, what is the headline of the current thread on this subject and roughly when was it posted (to make my stressed life a bit easier)
 
OP
3

380560

Senior Member
Joined
Jul 22, 2008
Messages
144
Reaction score
0
Location
Isle of Skye Highlands
Your Mercedes
S Class, W140 4.2 Limo, Nissan 300ZX twin turbo, Porsche 911.
  • Thread Starter
  • Thread starter
  • #14
...............i think i have just found the link if its the 280 one.....I will try and look at the car tomorrow as it is very wet and getting dark up here on Isle of Skye. Hey question.............are there any MB meetings up in the highlands area?
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Thank you Alex and I have sent him the paper,,not that much on it, but enough
 
OP
3

380560

Senior Member
Joined
Jul 22, 2008
Messages
144
Reaction score
0
Location
Isle of Skye Highlands
Your Mercedes
S Class, W140 4.2 Limo, Nissan 300ZX twin turbo, Porsche 911.
  • Thread Starter
  • Thread starter
  • #17
S Class W140 heater booster problem

SORRY GUYS I PLACED THIS AGAINST THE THREAD I WAS READING AT THE TIME.THIS IS THE CORRECT THREAD.

Hi Again.Firstly thanks to everyone who has helped me so far ref this issue, as they say "you know who you are"..........anyway after all that here is the latest on this matter. I removed the plastic cover as advised. The filter was pretty well filled with decomposing leaves. I have removed said filter and this will be replaced. Again as advised this would show the booster, there was rust around the centre, so I have sprayed it with WD40. The fan turns, but appears only at one speed and when I press the screen demist button the temp heater dials show HI, but only a slight "blow" is felt at the screen vents as it is from the other vents when the relevent buttons are pressed and heat controls moved.....so again your combined help is still required please.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
As the fan only runs at one speed,,you just replace the regulator, and that will solve it
 
OP
3

380560

Senior Member
Joined
Jul 22, 2008
Messages
144
Reaction score
0
Location
Isle of Skye Highlands
Your Mercedes
S Class, W140 4.2 Limo, Nissan 300ZX twin turbo, Porsche 911.
  • Thread Starter
  • Thread starter
  • #19
Thanks again, again, I will try and buy one and let you know.
 

star

Forum Supporter
Authorised Forum Supporter
Joined
Oct 6, 2004
Messages
5,875
Reaction score
1,324
Location
Reading
Your Mercedes
Smart + others :)
Just had the same today, wiggle the wires on the motor, this will move the brushes and the motor might speed up, as mine did today. So i need to source some brushes as the motor/fan is £603 +vat and thats without the regulator. I know some brushes were available from the usa but have lost the site, any idea's.
 


Save 30% on RAC Breakdown Cover
This year...next year... and every year you stay with RAC
Prices start from only £35.35*
This offer is available to all MERCEDES CLUB members and their immediate family**
Top Bottom