S350/2003- command unit not turning on at all

Can anyone help me with this problem?

  • Radio not working

    Votes: 0 0.0%
  • Air suspension

    Votes: 0 0.0%

  • Total voters
    0

Omar1994

New Member
Joined
Oct 28, 2018
Messages
7
Reaction score
3
Your Mercedes
S class / 2003 / 3.7l
I have a Mercedes S-class 2003 3.7l and a few days a go I replaced the rear air suspensions and a new compresses aswell. Once the battery was reconnected the air suspension sign pop up on the dash board but when raising and lowering the car it works perfectly fine. But driving over speed humps or small pot holes feel very uncomfortable. The main problem is the command unit, I tried to turn it in but doesn’t seem to turn on. also the digital clock on the dash doesn’t show.

Can anyone help me, as I don’t know what’s causing this problem
 

LostKiwi

Senior Member
Joined
Aug 25, 2006
Messages
26,860
Reaction score
16,394
Location
Midlands / Charente-Maritime
Your Mercedes
'93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
Have you checked fuses? They'll be listed on a card in the fuse box or in your owners manual.
 

alexanderfoti

MBO Forum Supporter
Authorised Forum Supporter
Joined
Mar 25, 2010
Messages
13,388
Reaction score
3,486
Location
Tonbridge
Your Mercedes
W221 S65 AMG - W204 C63 AMG + Various other MB's
If you have the airmatic warning still on the dash, then there is an active fault code, probably to do with the valve block considering your hard ride.
 
OP
O

Omar1994

New Member
Joined
Oct 28, 2018
Messages
7
Reaction score
3
Your Mercedes
S class / 2003 / 3.7l
  • Thread Starter
  • Thread starter
  • #4
Yeah I’ve checked the fuses and everything seems to be fine. Just don’t know what’s the problem
 
OP
O

Omar1994

New Member
Joined
Oct 28, 2018
Messages
7
Reaction score
3
Your Mercedes
S class / 2003 / 3.7l
  • Thread Starter
  • Thread starter
  • #5
If you have the airmatic warning still on the dash, then there is an active fault code, probably to do with the valve block considering your hard ride.
The vavlue, above the compress seems to be fine and no leaks just checked now
 

alexanderfoti

MBO Forum Supporter
Authorised Forum Supporter
Joined
Mar 25, 2010
Messages
13,388
Reaction score
3,486
Location
Tonbridge
Your Mercedes
W221 S65 AMG - W204 C63 AMG + Various other MB's
If you have the airmatic warning still on the dash, then there is an active fault code, probably to do with the valve block considering your hard
The vavlue, above the compress seems to be fine and no leaks just checked now

Not that its leaking, but that it has an electrical fault. You need to read the codes in the airmatic ECU.
 


Over 100 branches Nationwide, More than 114,000 Parts in Stock, The UKs Largest, and Fastest Growing Parts Supplier,please see MBO Members’ Area for discount codeEuro Car Parts Ltd
Top Bottom