1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SL 300 Auto 1991

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by spiro, Oct 30, 2012.

  1. spiro

    spiro New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Dec 8, 2006
    Location:
    Edinburgh
    Help!

    My wife bought me this car six years ago for my birthday and I am slowly getting it restored back to showroom condition. It has 75,000 miles on the clock. Mercedes have worked on the mechanics and on the electrics, fitting a new ignition switch and instrument cluster. They could not carry over the last mileage because there is no facility to do so.

    My problem is this: If the engine is switched off, it won't immediately start again. The engine either turns over, but will not start, or it won't turn over at all. The remedy is to leave it alone for 30 mins and then it starts no problem. Mercedes have experienced this problem themselves, but cannot find anything wrong with the car and have asked me to contact this forum for advice.
     
  2. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    274
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    This is not easy,,, it has the new ignition switch so it has to be a poor connection, and this one has the MB fitted alarm immobiliser , a bad connection on the K38 starter lock out relay if fitted is a known fault, but that would not stop it from starting if the engine is turning over.

    When you turn the key does the dash all light up as normal
     
  3. WG M-B

    WG M-B Senior Member Authorised Forum Supporter

    Messages:
    3,105
    Likes Received:
    5
    Joined:
    Dec 5, 2010
    Location:
    North west london
    Your Mercedes:
    C63 Wagon in black
    I would just look at the simple things like a good spark and fuel pressure
    It's unlikely to be much else
     
  4. robparker

    robparker Senior Member Authorised Forum Supporter

    Messages:
    2,626
    Likes Received:
    310
    Joined:
    Apr 18, 2006
    Location:
    Taunton
    Your Mercedes:
    560SEC, 300SL, C43, + SLK200 for herself
    Haha, Mercedes advised to contact a forum! Shows how lost some of these new guys must be if you can't just plug it in!
     
  5. robparker

    robparker Senior Member Authorised Forum Supporter

    Messages:
    2,626
    Likes Received:
    310
    Joined:
    Apr 18, 2006
    Location:
    Taunton
    Your Mercedes:
    560SEC, 300SL, C43, + SLK200 for herself
    It does almost sound like 2 different problems. Turning over and not firing could be a hot sensor somewhere that needs to cool down, or condensation in the dizzy cap. But nothing that would stop it turning over, like a sticky starter motor, or just bad connection/earth etc somewhere
     
    Last edited: Oct 31, 2012

Share This Page