SL55 erratic gearbox issue.

guitar

Senior Member
Joined
Jan 23, 2010
Messages
81
Reaction score
9
Location
Essex east of London
Your Mercedes
SL55 AMG. 2004
Every now and then, and becoming more frequent, my SL55 seems to make an awkward gear change, and then gets stuck in one gear.
By "awkward" I mean it doesn't glide into gear, but rather jumps.
When I stop and switch off for a few moments, everything is fine after re start, and the box goes through the gears as it should.
Not sure if this is a mechanical or electrical issue. Anyone had similar problems, and was the cure expensive ? :)
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
40
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
It may be many things, but I would guess mechanical/hydraulic, eg:

Valve body
Clutch plates
Clutch o-ring

You get the idea.
As a general rule, diagnosing faults with the 722.6 box takes more than just a look at the fault codes - you need specific knowledge of the common faults and fault scenarios, or just use a specialist that does.

Is this fault worse with more right foot?
Or with temperature?
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
341
Age
87
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Is it always perfect after a re start for the rest of the running
 
OP
guitar

guitar

Senior Member
Joined
Jan 23, 2010
Messages
81
Reaction score
9
Location
Essex east of London
Your Mercedes
SL55 AMG. 2004
  • Thread Starter
  • Thread starter
  • #4
Is it always perfect after a re start for the rest of the running

Yes, so far. It first happened while I was visiting Devon,after a drive of 200 miles, after re start was fine for another few hundred miles.
There doesn't seem to be any provocation relating to driving style, or temperature. It has now happened around four times. Short trips, normal temperatures and easy driving.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
341
Age
87
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
I wonder if the fault is electrical, the box ECU is just under the dash. the pilot bush if leaking can push fluid up the cable into this ECU. Some say it can affect the box, but mine never did when the pilot bus leaked, this makes it hard but easy to fix. The gearbox ECU memory is tiny, have this cleared may help.
 
OP
guitar

guitar

Senior Member
Joined
Jan 23, 2010
Messages
81
Reaction score
9
Location
Essex east of London
Your Mercedes
SL55 AMG. 2004
  • Thread Starter
  • Thread starter
  • #7
You could answer these questions too, so I can help more.
Sorry Alex, I did answer in the post above,
Driving style, hard or easy doesn't seem to have any bearing on the issue, and it has happened both after a long drive, and short, so I don't feel temperature has much to do with it either.
I went to Goodwood FOS on Sat and the car was fine all the way there, after leaving I got a couple of miles when the car seemed to jump into 4th gear harshly and made a short kind of screeching sound. Then it was stuck in forth only. I pulled over switched off, and re started, car was fine for the rest of the 2hr journey.
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
40
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
Sorry Alex, I did answer in the post above,
Driving style, hard or easy doesn't seem to have any bearing on the issue, and it has happened both after a long drive, and short, so I don't feel temperature has much to do with it either.
I went to Goodwood FOS on Sat and the car was fine all the way there, after leaving I got a couple of miles when the car seemed to jump into 4th gear harshly and made a short kind of screeching sound. Then it was stuck in forth only. I pulled over switched off, and re started, car was fine for the rest of the 2hr journey.

Goodwood sounds amazing, a friend went with work and had a blast, although the glorious weather helps I imagine!

My advice would be the same regarding what might or might not be at fault, but very hard to guess at I'm afraid.
The 'screeching' sound does not bode well though - good luck.
 

Mitsywoo

New Member
Joined
Jul 15, 2013
Messages
7
Reaction score
0
Location
Nottinghamshire
Your Mercedes
CLK 320 Sport Auto 1999
Hi I have a CLK 320 sport and have been having the same problem for a number of years. It started sticking in 1st then jumping into 2nd gear and usually when the engine was cold, first use of the day and very occasionally. However it did happen on a road test once, whilst in for other repairs, but showed no fault code when they got it back to the garage. Now kick down and rapid acceleration do not work, I dare not overtake without plenty of room for eventual acceleration :( I suspect the first problem could be something to do with the ECU unit, as sometimes when the car is started and driven a few hundred yards, it will start to rock or shake and I have to pull over, switch off then on again and it drives smooth. I have been told, that over time engine oil can travel up the loom. :(( not sure about this tho.
 
Last edited:

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
341
Age
87
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Hi I have a CLK 320 sport and have been having the same problem for a number of years. It started sticking in 1st then jumping into 2nd gear and usually when the engine was cold, first use of the day and very occasionally. However it did happen on a road test once, whilst in for other repairs, but showed no fault code when they got it back to the garage. Now kick down and rapid acceleration do not work, I dare not overtake without plenty of room for eventual acceleration :( I suspect the first problem could be something to do with the ICU unit, as sometimes when the car is started and driven a few hundred yards, it will start to rock or shake and I have to pull over, switch off then on again and it drives smooth. I have been told, that over time engine oil can travel up the loom. :(( not sure about this tho.

One known problem on a car of this year is the connection on the gear box ECU the 2 end pins are the CAN connections and these can give a poor contact, clean them with a good non drying switch cleaner and see.

Another thing for the same years when it locks on and will not change is a sticking valve in the valve block and fairly easy to fix
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
40
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
...sometimes when the car is started and driven a few hundred yards, it will start to rock or shake and I have to pull over, switch off then on again and it drives smooth...

The above is indicative of an engine problem, rather than a gearbox problem - I suggest you start a new thread, as your issue is different to the issue this SL55 is having.
 

Miffy

Senior Member
Joined
Sep 6, 2008
Messages
7,356
Reaction score
4
Location
Bromley, London
Your Mercedes
CLK 320 CAB Elegance C208
Hi I have a CLK 320 sport and have been having the same problem for a number of years. It started sticking in 1st then jumping into 2nd gear and usually when the engine was cold, first use of the day and very occasionally. However it did happen on a road test once, whilst in for other repairs, but showed no fault code when they got it back to the garage. Now kick down and rapid acceleration do not work, I dare not overtake without plenty of room for eventual acceleration :( I suspect the first problem could be something to do with the ECU unit, as sometimes when the car is started and driven a few hundred yards, it will start to rock or shake and I have to pull over, switch off then on again and it drives smooth. I have been told, that over time engine oil can travel up the loom. :(( not sure about this tho.

Its time to get your errors read out on star
 
OP
guitar

guitar

Senior Member
Joined
Jan 23, 2010
Messages
81
Reaction score
9
Location
Essex east of London
Your Mercedes
SL55 AMG. 2004
  • Thread Starter
  • Thread starter
  • #14
Just an update, the issue was diagnosed and repaired by Andy at PCD.
An electrical switch plate, in the gearbox. Gear fluid and filter changed too, and the gear changes are better than they have ever been. :D
Thanks Andy !!
 


ALL MBO Club members qualify for 15% discount on second hand parts.Please see MBO Members’ Area for discount codewww.dronsfields.com
Top Bottom