slk 230 auto

jws

Senior Member
Joined
Dec 1, 2010
Messages
65
Reaction score
1
Location
London
Your Mercedes
1998 230SLK /c220 estate 55 reg
Hi took it for run after rest bite , went to get petrol started ok went for run again still going good ,went out next morning it wouldn't start ,came back that day it started ok , now wont start again , charged battery it spins over wont start , disconnected battery and reconnected still wont start spinning over well ,do the have fuel filter in line or main filter somewhere as I cant see it ,it like its not getting fuel any help please
 

LostKiwi

Senior Member
Joined
Aug 25, 2006
Messages
26,464
Reaction score
15,913
Location
Midlands / Charente-Maritime
Your Mercedes
'93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
Sounds like may be a bad Crank Position Sensor. Possibly also fuel pump or relay (if they have a relay).
 
OP
jws

jws

Senior Member
Joined
Dec 1, 2010
Messages
65
Reaction score
1
Location
London
Your Mercedes
1998 230SLK /c220 estate 55 reg
  • Thread Starter
  • Thread starter
  • #3
yeah was thinking fuel pump or bad connection on it
 

LostKiwi

Senior Member
Joined
Aug 25, 2006
Messages
26,464
Reaction score
15,913
Location
Midlands / Charente-Maritime
Your Mercedes
'93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
Get it on a code reader to find out.
 
  • Like
Reactions: jws


Mercedes-Benz Servicing, repairs, engine and diagnostics
Wayne Gates - Mercedes-Benz, Unit F3, Phoenix Industrial Estate, Rosslyn Crescent, Harrow, Middlesex, HA1 2SP
Tel: 020 8863 9233
Established for 20 years all vehicles washed and vacuumed.
Top Bottom