1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

some advice needed

Discussion in 'Engine, Drivetrain, Fuel and Exhaust' started by blairyboy75, Nov 13, 2012.

  1. blairyboy75

    blairyboy75 New Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    Nov 13, 2012
    Location:
    falkirk
    Your Mercedes:
    c250 turbo diesel
    Hi folks new to this site and was looking for a bit info on my Mercedes c250 turbo diesel . Its a 1999 on a v plate my problem is when I stick it in drive it drives fine then sometimes feels like its stuck in one gear also my speedo won't work when this is happening . The ESP light is staying on could this be the problem or something else . Anyone's advice would be much appriciated
     
  2. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    277
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    I think its worth changing the brake lamp switch to fix this at £12, it sits on top of the brake pedal
     
  3. OP
    blairyboy75

    blairyboy75 New Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    Nov 13, 2012
    Location:
    falkirk
    Your Mercedes:
    c250 turbo diesel
    Would that be the problem with the gears
     
  4. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    277
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    The brake lamp switch can kill off the speed signal within the ECU and without a speed signal the box does not know what to do and so it locks up in 2nd, its the cheapest and easiest thing to try
     
  5. OP
    blairyboy75

    blairyboy75 New Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    Nov 13, 2012
    Location:
    falkirk
    Your Mercedes:
    c250 turbo diesel
    OK thanks I all try that . If the speedo is sitting at say thirty sometimes it will just drop right down
     
  6. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    277
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    Lets see if someone else has a view on this
     
  7. Steve@Avantgarde

    Steve@Avantgarde Forum Supporter Authorised Forum Supporter

    Messages:
    6,808
    Likes Received:
    961
    Joined:
    Dec 8, 2009
    Location:
    Bristol/Somerset
    Your Mercedes:
    C220CDI AMG Line Premium, SLR McLaren Roadster, SL55 & C32AMG
    More likely to be a wheel speed sensor at fault. The speedo takes a total speed reading and divides it by 4 to give you the speed on the instrument cluster, this it cannot do if it is missing a value or if 1 value on 1 wheel is higher/lower than the other 3. The gear selection process also takes a value of road speed to shift gears and the ABS/ESP light is on to tell you there is a fault in that system.

    You need a STAR diagnosis test to look at the fault memory and you can test each sensor with the actual values function for an accurate diagnosis.
     
    Last edited: Nov 14, 2012
  8. OP
    blairyboy75

    blairyboy75 New Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    Nov 13, 2012
    Location:
    falkirk
    Your Mercedes:
    c250 turbo diesel
    So its more likely to be a speed sensor rather than a brake light switch
     
  9. Steve@Avantgarde

    Steve@Avantgarde Forum Supporter Authorised Forum Supporter

    Messages:
    6,808
    Likes Received:
    961
    Joined:
    Dec 8, 2009
    Location:
    Bristol/Somerset
    Your Mercedes:
    C220CDI AMG Line Premium, SLR McLaren Roadster, SL55 & C32AMG
    Correct. But you need a STAR test to confirm
     
  10. OP
    blairyboy75

    blairyboy75 New Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    Nov 13, 2012
    Location:
    falkirk
    Your Mercedes:
    c250 turbo diesel
    OK bought a brake light switch just out of curiosity but problem is still there . What does this wheel speed sensor come under is it different from a abs sensor
     
  11. Steve@Avantgarde

    Steve@Avantgarde Forum Supporter Authorised Forum Supporter

    Messages:
    6,808
    Likes Received:
    961
    Joined:
    Dec 8, 2009
    Location:
    Bristol/Somerset
    Your Mercedes:
    C220CDI AMG Line Premium, SLR McLaren Roadster, SL55 & C32AMG
    There are 4 wheel speed sensors, one on each hub, if you get a STAR test done you will be able to have it all tested and see which one is faulty.
     
  12. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    277
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    Sorry about the brake switch, but if a wheel sensor the ABS lamp should be on.

    The ESP rides on top of the ABS , for you to lose the the speedo, the speed signal is dropping out or being taken out. Is there a short maybe in a ESP module
     
  13. OP
    blairyboy75

    blairyboy75 New Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    Nov 13, 2012
    Location:
    falkirk
    Your Mercedes:
    c250 turbo diesel
    Its OK was only nine pound . The abs light and ESP light are constantly on
     
  14. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    277
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    OK this is the first time that you have said the ABS lamp is on so it will be a wheel sensor, as you are loosing a speed signal for the speedo and box it should be a front wheel on as Steve said
     
  15. OP
    blairyboy75

    blairyboy75 New Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    Nov 13, 2012
    Location:
    falkirk
    Your Mercedes:
    c250 turbo diesel
    Sorry should have said in the first place lol . So defo front sensor . Got it booked in for diagnostic check also . Is it a hard job fitting one if I was to tackle it myself
     
  16. Steve@Avantgarde

    Steve@Avantgarde Forum Supporter Authorised Forum Supporter

    Messages:
    6,808
    Likes Received:
    961
    Joined:
    Dec 8, 2009
    Location:
    Bristol/Somerset
    Your Mercedes:
    C220CDI AMG Line Premium, SLR McLaren Roadster, SL55 & C32AMG
    On paper no, not hard at all. You will have fun if the sensor sticks in the hub though!
     
  17. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    277
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    32 is the speed sensor

    [​IMG]
     
  18. OP
    blairyboy75

    blairyboy75 New Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    Nov 13, 2012
    Location:
    falkirk
    Your Mercedes:
    c250 turbo diesel
    Right folks help needed again . When car is started from cold it drives perfect in drive can even use the triptronic gears and work fine seems to be when car heats up that's when the speedo stops working and the gearbox seems to stay in the gear its in and you can't seem to sort it unless u stop the car and switch engine off and start again . It will then drive fine for a short while and then do the exact same thing
     
  19. Steve@Avantgarde

    Steve@Avantgarde Forum Supporter Authorised Forum Supporter

    Messages:
    6,808
    Likes Received:
    961
    Joined:
    Dec 8, 2009
    Location:
    Bristol/Somerset
    Your Mercedes:
    C220CDI AMG Line Premium, SLR McLaren Roadster, SL55 & C32AMG
    Have you got any fault codes yet?:
     

Share This Page