1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sprinter lacking power

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by Kivison, Sep 30, 2019.

  1. Kivison

    Kivison New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Sep 29, 2019
    Your Mercedes:
    311 sprinter 2.2 diesel 2005
    Hi all. New to the group. I have just bought a sprinter 311cdi van 2005 106k miles. It is lacking in power over 3000revs when pulling away the power will markedly retard as I hit that rev. Going up hills at 60mph will slow down to 50 and be unable to increase speed even when dropping a gear... There is a whine that accompanies the engine tone that goes up and down with the rev even in neutral. Could this be the turbo or a cat issue? Is there a way of testing or isolating? One other thing which may be a red herring to the problem but I read it on another thread iwith a similar issue s the glow plug warning light comes on after start and stays on for a bit till its warm.

    Thanks in advance

    Keith
     
  2. alexanderfoti

    alexanderfoti MBO Forum Supporter Authorised Forum Supporter

    Messages:
    12,425
    Likes Received:
    2,724
    Joined:
    Mar 25, 2010
    Location:
    Tonbridge
    Your Mercedes:
    W221 S65 AMG - W204 C63 AMG + Various other MB's
    Read the codes and take it from there.
    Its in limp mode, which can have a million causes, no point in guessing which.
     
    LostKiwi likes this.
  3. OP
    Kivison

    Kivison New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Sep 29, 2019
    Your Mercedes:
    311 sprinter 2.2 diesel 2005
    Thanks alexanderfoti,

    Ah, so I assume the glow indicator light means limp mode then does it? I didn't get a manual with it so non the wiser I'm afraid. There are no other lights on the dashboard or errors including check engine (which I would have thought would display in something like limp mode)

    K
     
  4. alexanderfoti

    alexanderfoti MBO Forum Supporter Authorised Forum Supporter

    Messages:
    12,425
    Likes Received:
    2,724
    Joined:
    Mar 25, 2010
    Location:
    Tonbridge
    Your Mercedes:
    W221 S65 AMG - W204 C63 AMG + Various other MB's
    No the glow indicator tells you one or more glow plugs are not functioning, but this is not related to your limp mode. Many mbs go onto limp mode with no check engine light. (its an mb thing)
     
  5. OP
    Kivison

    Kivison New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Sep 29, 2019
    Your Mercedes:
    311 sprinter 2.2 diesel 2005
    So, my ODBII reader is a 16 pin and the Sprinter is a 14 pin (round) so I have it booked into a garage tomorrow to see whats going on. Will let you know. Thanks for posting back.

    K
     
  6. davidsl500

    davidsl500 Senior Member

    Messages:
    4,139
    Likes Received:
    1,505
    Joined:
    Oct 24, 2004
    Location:
    Home : Derbyshire at the moment !
    Your Mercedes:
    R172 250CDI, R129 SL500 Gone...
    You can get an adaptor like this from Ebay Keith.
     
    Wildcamper likes this.
  7. LostKiwi

    LostKiwi Senior Member

    Messages:
    24,239
    Likes Received:
    13,411
    Joined:
    Aug 25, 2006
    Location:
    Midlands / Charente-Maritime
    Your Mercedes:
    '93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
    You can but depending what the reader is there's no guarantee it'll work (depending on supported protocols).
     
  8. supreme vikings

    supreme vikings New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Sep 24, 2019
    Location:
    Pakistan
    Your Mercedes:
    1992 corolla 1.2

Share This Page