1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

This ****** car!!!!!

Discussion in 'Engine, Drivetrain, Fuel and Exhaust' started by Dean Fletcher, May 16, 2019.

  1. Dean Fletcher

    Dean Fletcher Senior Member

    Messages:
    577
    Likes Received:
    256
    Joined:
    Mar 24, 2018
    Your Mercedes:
    Mercedes e 250 coupe AMG 2009
    Hi chaps,
    This cars doing my nuts in.
    Yesterday got in it to go to work and it was in limp mode. So I plugged in the reader and exhaust temp sensor bank 1 range/performance. The problem is the car has had the sensor replaced a fee months ago. Its had both oxygen sensors done and dpf pressure sensor done. Last time it was at the indy he said (after changing sensors realising it wasnt the actual sensor) that the ECU plug was slightly out and dirty.
    He cleaned it up and put it back all was fine for 8 weeks then 4 weeks later the same thing so I pushed the plug in and another for 4 weeks all fine then this week same happens again.
    What could it be? The indy was on about wanting to strip the wires as the car might have a ground wire somewhere? And with a cost of around 600 to 700 quid. Mainly labour.
    I had a MOT last year and the guy said the exhaust flexi was loose but not blowing. Could this be the culprit? Are fumes escaping making the sensor show dodgy reading?
    Or could it be the ECU connection? Orrrrrr is there a chance that the o2 sensor is faulty.
    Mr Indy said he tested both sensors and both were fine but one was over the required 50°c difference reading. Which flags up.
    The codes have always been pending codes hence the eml hasn't come on.
    Soon as I start the car limp mode drive for a minute stop start no limp mode. ??
    I'm racking my what little Brain's I have.
    Thanks guys
     
  2. Steve@Avantgarde

    Steve@Avantgarde Forum Supporter Authorised Forum Supporter

    Messages:
    6,789
    Likes Received:
    937
    Joined:
    Dec 8, 2009
    Location:
    Bristol/Somerset
    Your Mercedes:
    C220CDI AMG Line Premium, SLR McLaren Roadster, SL55 & C32AMG
    Firstly. Has the cars engine control unit been checked and updated? These sensors are very specific to software now.

    Secondly. There is a TIPs document available for this high frequency of fault code. Does your Indy have access to that? If so, he needs to follow the repair procedure.

    There can't be any guessing if the Indy is using STAR diagnosis with the correct software. If he carries out the guided fault finding, it will lead directly to the fault.
     
    Dean Fletcher likes this.
  3. OP
    Dean Fletcher

    Dean Fletcher Senior Member

    Messages:
    577
    Likes Received:
    256
    Joined:
    Mar 24, 2018
    Your Mercedes:
    Mercedes e 250 coupe AMG 2009
    Yes I'm sure he has access to that. He put it on star last time and said he couldn't find anything wrong. He even took it home tested it over 3 days with constant cold to hot starts and monitored the warming up process. The 2 sensors were reading different temp by over 50 degrees. Both sensors are good. All he said he done was noticed the ECU plug was out slightly so cleaned it up and it's been good for months. Last time it was in there was a software update which he performed. Thanks
     
  4. mattkh

    mattkh Senior Member

    Messages:
    1,459
    Likes Received:
    14
    Joined:
    Aug 2, 2006
    Location:
    England
    Your Mercedes:
    W168 1999 1.6
    The connection to the car's ECU is the most important connection. Why does it keep getting out???
     
    Dean Fletcher likes this.
  5. OP
    Dean Fletcher

    Dean Fletcher Senior Member

    Messages:
    577
    Likes Received:
    256
    Joined:
    Mar 24, 2018
    Your Mercedes:
    Mercedes e 250 coupe AMG 2009
    God knows the left plug is fine doesn't move at all the right plug pulls out by about a cm. Iv decided to take drastic action and glued it the other day.:) had it on star today and guess what no codes.
     
    d215yq and Wighty like this.
  6. Wighty

    Wighty Senior Member

    Messages:
    6,117
    Likes Received:
    3,319
    Joined:
    Aug 4, 2016
    Location:
    Sunny Essex
    Your Mercedes:
    W211/E320cdi/2009 and CLK200k 2009
    Fingers crossed that sorted it buddy :D ! You'll be back in love with it soon .
     
    Dean Fletcher likes this.
  7. OP
    Dean Fletcher

    Dean Fletcher Senior Member

    Messages:
    577
    Likes Received:
    256
    Joined:
    Mar 24, 2018
    Your Mercedes:
    Mercedes e 250 coupe AMG 2009
    I do love the little gem BUT it's like having a 3rd child always need attention it's like it gets jealous if I buy the kids something. HOLD ON YOU HAVE BOUGHT YOUR KIDS SOMETHING NOW YOU MUST SPEND ££££££s ON ME. plus we go on holiday tomorrow and o think I knows. Just doesn't want to be by it self for a week in liverpool airport Haha :(:(:(:mad::(:(:(
     
    Wighty and daibevan like this.
  8. John Laidlaw

    John Laidlaw Senior Member

    Messages:
    19,589
    Likes Received:
    5,274
    Joined:
    Nov 15, 2013
    Location:
    Wirral
    Your Mercedes:
    UnMercs BMW i8 Volvo XC90
    Neither would I to be fair :p
     
    Dean Fletcher and Wighty like this.

Share This Page