Two niggles on one day

barnaclebill15

Senior Member
Joined
Mar 24, 2015
Messages
263
Reaction score
67
Location
newcastle upon tyne
Your Mercedes
clk220cdi/2006/diesel
On a long run today all running well, winding road 25% up doing 40 ok, 10 minutes later on the flat at a roundabout notice the temperature is only 75c, it had been 87c before. Speed up and the temp begins to slowly rise to about 85. Next a 20% down winding road changed to manual down to third all ok, level off change up to D again ok. Get onto normal country road fairly straight but a few up and down sections doing about 40 in a line of cars going up, they are moving away and I notice i am pressing the accelerator but not speeding up and the box has not changed down, go over the brow of the hill car speeding up ok.
Next roundabout i change to manual, almost stopped when I change so it goes into first so I quickly go to 2 then up the box all ok. Go back to auto but still feel if doing 40 on a slight incline up and want to speed up to 60 it is not changing down but slowly rising up.
Get on the dual carriageway doing 65 most of the time feels ok but on some up slopes slow to speed up, final part before home is a long 50 limit, at the end of it notice the temp is 80c, speed up to 60 and the temp rises to 85c in about 20 seconds, 30 limit to home for about 2 miles and back to 87c when I stop.
No alarms, I have been driving slowly for economy for a few months so wondered if the adaptive gearbox has decided this.
The temperature does not look like thermostat to me the way it increased 5c in 20 secs, more like poor circulation.
Any thought welcome
 

Ken_R

Senior Member
Joined
Dec 11, 2015
Messages
691
Reaction score
201
Location
Worcestershire, UK
Your Mercedes
W203 2006 C230 Estate
Almost certainly Thermostat. I drive c10 miles each way, work and back, country lanes and, once up to temperature, it is 'rock solid' on the gauge.
 

Chrishazle

Senior Member
Joined
May 25, 2009
Messages
3,956
Reaction score
1,514
Location
Nr Ashford, Kent
Your Mercedes
S204 2008 C220CDI Elegance Estate Auto, 2008 R171 Facelift SLK280
Kickdown not working - if you also find car will not rev above 3k RPM - would make me suspect MAF rather than thermostat - as that's what happened with my s203 within a month of buying it. Luckily it had a warranty, MAF changed, problem solved.

I later had the thermostat problem, but that was signalled by the heater being useless and taking forever to kick in, and the temp gauge seldom if ever getting above 60C. Thermostat change cured that! Just had the same on the S204!
 
OP
barnaclebill15

barnaclebill15

Senior Member
Joined
Mar 24, 2015
Messages
263
Reaction score
67
Location
newcastle upon tyne
Your Mercedes
clk220cdi/2006/diesel
  • Thread Starter
  • Thread starter
  • #4
32 months since I changed the thermostat, only the second time I had to change one on over 30 cars in fifty years so not a long life on these, as for the MAF looking on here people seem to have more than kickdown not working if the MAF has gone but it could be.
Just one other thing, seems to be changing up fast through the gears when i pull away from stop.
 
Last edited:
OP
barnaclebill15

barnaclebill15

Senior Member
Joined
Mar 24, 2015
Messages
263
Reaction score
67
Location
newcastle upon tyne
Your Mercedes
clk220cdi/2006/diesel
  • Thread Starter
  • Thread starter
  • #5
Ok after spending time searching about MAF changing and cleaning drove out, temp was 1.5C and snowing, car behaved as normal kickdown ok and temp rose up to 87C and stayed constant so hope it stays like this.
 


Chris Knott Insurance, see oursticky posts here!
www.ckinsurance.co.uk
Top Bottom