two things wrong with my vito 108cdi HELP

prestige valeters

New Member
Joined
Jul 22, 2009
Messages
2
Reaction score
0
hi all new to the site will have alook around, but first i have some probs with my vito 108 cdi. to start of with i was getting some smoke coming from behind the engine and a puffing sound so my first thought was the exhaust gaskit so ive had the turbo off and exhaust and replaced the gaskit. got it all back together to find out it wasnt that but when looking from under the van it still looks like its coming from there or just above,

is there any pipes there that could of gave way?

2nd thing is once it was running again when reving it the boost hose now sucks in when before it pushed out and im not sure why its doing that, ive had alot of turbo cars and never come across this anyone know what could have made it start doing this? ive had some boost hose's off to remove the turbo but all was put back right and done up well.

any help would be helpfull as i need the van back on the road asap

thanks, martin
 
Last edited:

ernieh

Senior Member
Joined
Nov 20, 2006
Messages
1,528
Reaction score
115
Location
Scotland, East
Your Mercedes
205 / 67 / C220 d
Vito Injectors

Hi Martin,
Sorry for the late reply, but welcome to the forum anyway!

I think the first problem is a leaking injector seal. If you do a search under 'Vito Injectors' you will bring up a number of threads which I'm sure will help. However from the experience of others, it seems that access to some of these injectors is poor and that makes it a difficult job.

Not so sure about the other thing, though. I would check what you did earlier first of all as it looks to me like the turbo is pulling a vacuum due to a blockage. However, maybe I've misunderstood the symptoms as I'm no expert in these and somebody with a wider knowledge might come along and help.

Hope you get it sorted out OK.


Ernie
 
OP
P

prestige valeters

New Member
Joined
Jul 22, 2009
Messages
2
Reaction score
0
  • Thread Starter
  • Thread starter
  • #3
thanks for the reply you are right it was leaking thats all sorted now, but still my boost pipe is sucking in i played with the boost on the turbo and it stopped sucking and was fine but out of the blue its started doing it again once again ive tryed setting the boost but this time its not working,

i was told the other day that there is something on the clutch peddle that makes the boost come in im un sure how true this is tho
 


Mercedes-Benz Servicing, repairs, engine and diagnostics
Wayne Gates - Mercedes-Benz, Unit F3, Phoenix Industrial Estate, Rosslyn Crescent, Harrow, Middlesex, HA1 2SP
Tel: 020 8863 9233
Established for 20 years all vehicles washed and vacuumed.
Top Bottom