1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Unable to bluetooth yet again!

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by norwoodboy, Apr 10, 2019.

  1. norwoodboy

    norwoodboy Member

    Messages:
    20
    Likes Received:
    4
    Joined:
    Jun 21, 2014
    Your Mercedes:
    E350 2010
    Evening,

    Just set up my "New" Iphone 6 but i cannot get it to sync with the car (E350) 10 Plate , this is my third phone and every time i have had issues!
    So everything is on in the car and phone but although the car sees the phone the phone cannot find the car so cannot sync or get the 6 digit pass code.

    Any ideas?? i realise i am a bit thick on such things but it appears to be very simple??

    Cheers
     
  2. Tony Dyson

    Tony Dyson Senior Member

    Messages:
    884
    Likes Received:
    280
    Joined:
    Aug 26, 2018
    Location:
    God's Country
    Your Mercedes:
    2014 C 220 CDI W204 OM 651
    Make sure your phone and car is set to Bluetooth 'Discoverable'
    Turn off your ignition
    Reset your phone
    Turn on your ignition and see if that cures it?
     
  3. Wighty

    Wighty Senior Member

    Messages:
    6,243
    Likes Received:
    3,440
    Joined:
    Aug 4, 2016
    Location:
    Sunny Essex
    Your Mercedes:
    W211/E320cdi/2009 and CLK200k 2009
    Also delete the phone from the cars memory and start again with synching the phone to the car
     
    sonic likes this.
  4. sonic

    sonic Senior Member

    Messages:
    917
    Likes Received:
    291
    Joined:
    Nov 21, 2009
    Location:
    Staffordshire
    Your Mercedes:
    E350CDI, SLK200K, FJR 1300
    My 212 11 plate works all the time on both of our iPhone 6's. Occasionally the 171 10 plate won't connect to my wife's iPhone. Normally it will connect by just turning off Bluetooth then back on. Occasionally I have to delete the connection on the iPhone, & reconnect.
     
  5. Botus

    Botus Senior Member

    Messages:
    2,961
    Likes Received:
    530
    Joined:
    Jul 29, 2014
    Location:
    UK
    Your Mercedes:
    S500/2010/500
    when u say new iPhone....

    do you have the latest phone updates applied?
    apple don't follow standards and you always need at least 3 revisions of the phone operating system before Bluetooth is remotely stable
     
  6. OP
    norwoodboy

    norwoodboy Member

    Messages:
    20
    Likes Received:
    4
    Joined:
    Jun 21, 2014
    Your Mercedes:
    E350 2010
    Sorted.

    It would appear the phone was at fault, thanks for the comments.
     
    Wighty likes this.
  7. Jim2

    Jim2 Senior Member

    Messages:
    693
    Likes Received:
    360
    Joined:
    Jan 18, 2018
    Your Mercedes:
    2010 Eclass w212 2.1 CDI
    I have a similar problem with mine....was working perfectly, then the phone ( HTC M8 ) threw a wobbly, and I reset it to original settings. I go to "PHONE" in the Merc, and it's set at "Bluetooth Discoverable ", I do the same with the phone, make sure that it is also " Bluetooth Discoverable " then "Search", but they can't seem to find each other.. at a guess, I would say that it's linked to my resetting it to factory settings, but now, how to fix it?? Anyone else experience the same problem?
     
  8. Tony Dyson

    Tony Dyson Senior Member

    Messages:
    884
    Likes Received:
    280
    Joined:
    Aug 26, 2018
    Location:
    God's Country
    Your Mercedes:
    2014 C 220 CDI W204 OM 651
    Having reset your phone to factory settings did you restart the Bluetooth Service?
    Are the details of your phone in your car's 'Paired Devices' List?
    Are the details of your car in your phone's 'Paired Devices' list?
    Have you tried syncing your phone to another host?
    Have you tried syncing another phone to your car?
     
    Jim2 likes this.
  9. Botus

    Botus Senior Member

    Messages:
    2,961
    Likes Received:
    530
    Joined:
    Jul 29, 2014
    Location:
    UK
    Your Mercedes:
    S500/2010/500

    any issues its always apple at fault... they appear to just fumble about and hope it works, they refuse to follow protocols and industry standards and write there own junk code in the vain hope it might work at sometime in the future - regarding Bluetooth as you found out it seldom does. If you rely on in car comms NEVER update until 4 months after the next iOS release, since iOS5 there have always been at least 3 updates before it has any idea how to work....

    https://discussions.apple.com/thread/8540162
     
  10. Jim2

    Jim2 Senior Member

    Messages:
    693
    Likes Received:
    360
    Joined:
    Jan 18, 2018
    Your Mercedes:
    2010 Eclass w212 2.1 CDI
    Hi Tony,
    In the car, it show's the HTC M8 as a connected device, but the mobile is not showing any nearby devices ( including the car) even though its in "Discovery" mode, and showing "Visible to all nearby Bluetooth devices." Should I uninstall / install Blue tooth on the phone, or what would you recommend? Thanks for your help.
     
    Last edited: Apr 15, 2019
  11. Srdl

    Srdl Senior Member

    Messages:
    2,126
    Likes Received:
    1,047
    Joined:
    Oct 8, 2015
    Location:
    Hampshire
    Your Mercedes:
    GLC43 AMG 2018 (X253) Premium Plus
    In the interests of balance, I have to say I have rarely, if ever, had problems with Bluetooth on either of the iPhones I have had.
     
    Jim2 likes this.
  12. Blobcat

    Blobcat Moderator

    Messages:
    13,696
    Likes Received:
    3,009
    Joined:
    Feb 8, 2006
    Location:
    Near Grange Moor (not Wakefield...)
    Your Mercedes:
    R171 SLK280 3.0, Land Rover 110 County SW
    Same and I keep my IOS up to date as well.
     
    Srdl and Jim2 like this.
  13. Jim2

    Jim2 Senior Member

    Messages:
    693
    Likes Received:
    360
    Joined:
    Jan 18, 2018
    Your Mercedes:
    2010 Eclass w212 2.1 CDI
    The Son-in-Laws Iphone works fine in the Merc too....its the HTC M8 that I have a problem with, ever since the phone threw a wobbly, and I had to reset it to original factory settings.But before that, it worked like a dream.
     
    Wighty likes this.
  14. Tony Dyson

    Tony Dyson Senior Member

    Messages:
    884
    Likes Received:
    280
    Joined:
    Aug 26, 2018
    Location:
    God's Country
    Your Mercedes:
    2014 C 220 CDI W204 OM 651
    Hello Jim, It sounds as though it’s your HTC M8 at fault although to confirm this, you should attempt to pair it to another host, or even just look for ‘Available Devices’ in your phone’s Bluetooth settings, you should see a fluid list of all available devices within range depending on your location. Assuming after your factory reset you updated the Phone’s Firm and Software, your service provider would be the next port of call to see if they can troubleshoot via the network, good luck!
     
    Jim2 likes this.
  15. Botus

    Botus Senior Member

    Messages:
    2,961
    Likes Received:
    530
    Joined:
    Jul 29, 2014
    Location:
    UK
    Your Mercedes:
    S500/2010/500

    yes its always perfect...


    iOS12 https://discussions.apple.com/thread/8540162

    iOS11 https://discussions.apple.com/thread/8111592

    iOS10 https://discussions.apple.com/thread/7785673

    iOS9 https://discussions.apple.com/thread/7517356

    iOS8 https://discussions.apple.com/thread/6680125

    iOS7 https://discussions.apple.com/thread/5365070


    after upgrading some unexpected problems may occur. Issues like broken Bluetooth connections, failed Bluetooth pairing, and Bluetooth audio in the car are frequently reported. We summarize the Bluetooth issues you may encounter.

    • Bluetooth Won’t Connect After iOS 12/11.4
    • Bluetooth Won’t Turn on on iPhone/iPad
    • iPhone Bluetooth Not Connecting to Car
    • Bluetooth Audio Stutters on iPhone/iPad
    • Fail to Initiate Calls Over Bluetooth on iPhone/iPad
    • iPhone Bluetooth Suddenly Disconnecting on Car
    • iPhone Bluetooth Connection Drops Frequently
     
    Jim2 likes this.

Share This Page