Vibration on e320 cdi

ad4m

New Member
Joined
Aug 11, 2009
Messages
6
Reaction score
0
Your Mercedes
e320 CDI 2003 Avangarde
Dear all,


I have recently came across a problem with my e320cdi 2003, basically the car vibrates when you accelerate but only between 1000-2000 revs and then during faster drive makes a noise like something was loose i had several mechanics trying to diagnose the problem but none of them could help. According to them prop shaft and doughnut are ok.

I hope someone can help please :confused:

Many thanks

Ad
 

rpe2

Senior Member
Joined
Sep 25, 2006
Messages
2,863
Reaction score
2
Age
44
Location
Silchester
Your Mercedes
His: 2018 E220 d; Hers: 2016 SMAX
Age of the car please.

...and welcome to the forums.
 

rpe2

Senior Member
Joined
Sep 25, 2006
Messages
2,863
Reaction score
2
Age
44
Location
Silchester
Your Mercedes
His: 2018 E220 d; Hers: 2016 SMAX
Sorry just re-read your post.

I'm afraid it sounds like it may be a valeo radiator problem.

Do a search on here, a good specialist will be able to do a test on the gearbox oil...
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Yes it does sound like the valeo rad fault where glycol gets into the gear box,,the symptoms are.

A humming or droning when pulling lightly in top at between 1200 and 2500 rpm.

As rpe2 any MB garage can do the test and it cost around £75,,if this comes out positive , the car will need a new torque converter and rad
 

Cole@MBS

Forum Supporter
Authorised Forum Supporter
Joined
Dec 1, 2008
Messages
13,654
Reaction score
812
Age
51
Location
Hedge End, Southampton
Website
www.mbssouthampton.co.uk
Your Mercedes
124 300 CE 24 Coupe, C220CDI, 1959:Morris Minor
Sorry just re-read your post.

I'm afraid it sounds like it may be a valeo radiator problem.

Do a search on here, a good specialist will be able to do a test on the gearbox oil...

See one last week Richard!!
 
OP
A

ad4m

New Member
Joined
Aug 11, 2009
Messages
6
Reaction score
0
Your Mercedes
e320 CDI 2003 Avangarde
  • Thread Starter
  • Thread starter
  • #6
Sorry just re-read your post.

I'm afraid it sounds like it may be a valeo radiator problem.

Do a search on here, a good specialist will be able to do a test on the gearbox oil...

Thank you very much for your reply just would like to add that gear box oil has been checked and when the car drives on higher then 2000 rpm there is no vibrations... Also when you drive on the motorway doing 70-80 mph and you accelerate aggressively it does sound like "booooooo" that's best i can describe..

Adam
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Thank you very much for your reply just would like to add that gear box oil has been checked and when the car drives on higher then 2000 rpm there is no vibrations... Also when you drive on the motorway doing 70-80 mph and you accelerate aggressively it does sound like "booooooo" that's best i can describe..

Adam

Has the fluid been checked for any glycol content
 
OP
A

ad4m

New Member
Joined
Aug 11, 2009
Messages
6
Reaction score
0
Your Mercedes
e320 CDI 2003 Avangarde
  • Thread Starter
  • Thread starter
  • #8
I am not sure i just been told by the mechanic that the oil is ok but he is not professional Mercedes mechanic so god knows i will have to simply do that test, if i have that problem how long you think i have before something falls apart and can i drive it like this at all or i should take it straight to the garage ??

Thanks
 
OP
A

ad4m

New Member
Joined
Aug 11, 2009
Messages
6
Reaction score
0
Your Mercedes
e320 CDI 2003 Avangarde
  • Thread Starter
  • Thread starter
  • #9
i also forgot to add when recently i put the gear box on "N" i could feel car going backwards.
 

rpe2

Senior Member
Joined
Sep 25, 2006
Messages
2,863
Reaction score
2
Age
44
Location
Silchester
Your Mercedes
His: 2018 E220 d; Hers: 2016 SMAX
'N' is a red herring, it will do that.

You should see a specialist who can test the gearbox oil for antifreeze (the oil cooler/ radiators break down). What you describe sound like classic symptoms.

Where are you located?

Oh, and to answer your other question, take it to a specialist as soon as possible.
 
OP
A

ad4m

New Member
Joined
Aug 11, 2009
Messages
6
Reaction score
0
Your Mercedes
e320 CDI 2003 Avangarde
  • Thread Starter
  • Thread starter
  • #11
'N' is a red herring, it will do that.

You should see a specialist who can test the gearbox oil for antifreeze (the oil cooler/ radiators break down). What you describe sound like classic symptoms.

Where are you located?

Oh, and to answer your other question, take it to a specialist as soon as possible.

Thank you for your reply im from Gillingham in Kent
 

OlafMaxwell

Senior Member
Joined
Apr 2, 2004
Messages
1,043
Reaction score
0
Location
Cork Ireland
Your Mercedes
W210 E320 CDI Estate
If its the Valeo problem you need to act quick. To be honest if its not I would recommend changing the radiator anyway because most of them go wrong and anyone buying it will immediately be checking this out.
 
OP
A

ad4m

New Member
Joined
Aug 11, 2009
Messages
6
Reaction score
0
Your Mercedes
e320 CDI 2003 Avangarde
  • Thread Starter
  • Thread starter
  • #13
Hello,

First thanks for all replies !
Just to give you guys an update on my merc i had it checked today and thanx god
is not the glycol in the gearbox. The problem was caused by the central support bearing (doughnut) on the prop shaft. The part is only 40£ from MB main dealer. Im really chuffed!!!

Thanks ones more

Adam
 


Comand (Europe) Ltd are the leading specialists in supplying and fitting Comand, Linguatronic, Media interface kits, UHI phone, IPod interfaces and much more.
Top Bottom