W140 problem please help

ashbcbg

Active Member
Joined
Mar 8, 2009
Messages
39
Reaction score
0
Location
Leicester
Your Mercedes
s280
Hi
My mate took our S280 to the car wash today and for some reason had the engine bay washed.The car ran okay for about 1 mile before she parked it.When she started the car minutes later,it sounded like it was missfiring and theres not enough power in it.When its idling its shaking/vibrating.Anyone knows what could be the likely problem coz it was running perfect before it was washed.:(
 

Dave Brooker

Senior Member
Joined
Jul 10, 2009
Messages
425
Reaction score
0
Hi
My mate took our S280 to the car wash today and for some reason had the engine bay washed.The car ran okay for about 1 mile before she parked it.When she started the car minutes later,it sounded like it was missfiring and theres not enough power in it.When its idling its shaking/vibrating.Anyone knows what could be the likely problem coz it was running perfect before it was washed.:(

Coil pack?
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
And water in anywhere where it should not be
 
OP
A

ashbcbg

Active Member
Joined
Mar 8, 2009
Messages
39
Reaction score
0
Location
Leicester
Your Mercedes
s280
  • Thread Starter
  • Thread starter
  • #4
Where in the engine bay can i find the coil packs?Is this something i can try and replace on my own and see if theres any difference?:confused:
 


A truly one stop site for Mercedes owners. Very experienced – friendly – down to earth – cost effective repairs offering either genuine or same quality parts so that you do not compromise your Mercedes heritage or reliability. Tel: 01406 422457fleetroadgarage.co.uk
Top Bottom