W163 Ml270 BAS ESP & ETS Lights on

Blueyes1971

Senior Member
Joined
Dec 3, 2010
Messages
238
Reaction score
36
Location
Midlands
Your Mercedes
2002 ML270 CDI Facelift
hi again all
When I turn engine on all lights go out as they should.
However as soon as I depress the brake to disengage the ebrake the BAS/ESP & ETS illuminate and stay on.
Therefore not allowing cruise control.
I have replaced the brake switch as I am also experiencing no brake lights .. and have swapped round the K25 relay .
The first time I swapped the relay for another it seemed to rectify the BAS etc lights and I had cruise control again. Then after a day it went back to same issue.... I’m thinking it could be the fault requires clearing with star and then a new relay will fix the issue without reaccurring... all help greatly appreciated as it’s essential I sort this ASAP.
Thanks all
 
OP
Blueyes1971

Blueyes1971

Senior Member
Joined
Dec 3, 2010
Messages
238
Reaction score
36
Location
Midlands
Your Mercedes
2002 ML270 CDI Facelift
  • Thread Starter
  • Thread starter
  • #2
Any insight or advice guys
 

LostKiwi

Senior Member
Joined
Aug 25, 2006
Messages
26,587
Reaction score
16,084
Location
Midlands / Charente-Maritime
Your Mercedes
'93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
Given the light goes out when you restart the engine I think it unlikely clearing codes in Star will make any difference.
I suppose you can try it as really you need to get codes read / run a few actuations to try to find the cause.
 

Craiglxviii

Senior Member
Joined
Sep 6, 2015
Messages
15,939
Reaction score
4,997
Location
Cambs UK
Your Mercedes
W215 CL500 Motorway Queen; W251 R320L Familybenz, S211 E320 Avg Designo Edition now sadly missed.
Has the battery been disconnected recently? If so the steering angle sensor may need resetting.

Engine in in Park.

Turn wheel lock to lock a few times. This establishes steering angle parameters.

Lights should go out.
 

benzmaester

Member
Joined
Sep 28, 2017
Messages
19
Reaction score
4
Your Mercedes
ML W163 320
Has the battery been disconnected recently? If so the steering angle sensor may need resetting.

Engine in in Park.

Turn wheel lock to lock a few times. This establishes steering angle parameters.

Lights should go out.
Agree with Craiglxviii give it a goc

Sent from my SM-G930F using Tapatalk
 
OP
Blueyes1971

Blueyes1971

Senior Member
Joined
Dec 3, 2010
Messages
238
Reaction score
36
Location
Midlands
Your Mercedes
2002 ML270 CDI Facelift
  • Thread Starter
  • Thread starter
  • #6
Given the light goes out when you restart the engine I think it unlikely clearing codes in Star will make any difference.
I suppose you can try it as really you need to get codes read / run a few actuations to try to find the cause.
Cheers Kiwi.
The lights come on and stay on as soon as I depress the brake, and no brake lights work
Cheers
 
Last edited:
OP
Blueyes1971

Blueyes1971

Senior Member
Joined
Dec 3, 2010
Messages
238
Reaction score
36
Location
Midlands
Your Mercedes
2002 ML270 CDI Facelift
  • Thread Starter
  • Thread starter
  • #7
Has the battery been disconnected recently? If so the steering angle sensor may need resetting.

Engine in in Park.

Turn wheel lock to lock a few times. This establishes steering angle parameters.

Lights should go out.
Cheers for the input but although I have recently replaced the battery for new, I have done the procedure many times....I did have the wheel alignment done a few months ago after replacing a ball joint and track rod end
 
OP
Blueyes1971

Blueyes1971

Senior Member
Joined
Dec 3, 2010
Messages
238
Reaction score
36
Location
Midlands
Your Mercedes
2002 ML270 CDI Facelift
  • Thread Starter
  • Thread starter
  • #8
I can understand lights staying on due to an issue requiring attention or requiring clearing with star, but can't understand the brake lights not working.
Am I right in thinking the loom beneath the washer bottle could have something to do with it?
Perhaps Alex or Malc could chime in with their two peneth
 

Taffy7hfa

Senior Member
Joined
May 29, 2016
Messages
1,242
Reaction score
550
Location
Oxford
Your Mercedes
2004 ML350 Inspiration .2002 ML270 CDI .2016 Hyundai i30 1.6crdi.2014 Peugeot 308 1.6 HDI.
Probably worth checking the loom next to the ABS unit, its really easy to see with the nearside headlight removed.
 

Wighty

Senior Member
Joined
Aug 4, 2016
Messages
10,846
Reaction score
8,178
Location
Sunny Essex
Your Mercedes
W211/E320cdi/2009 and CLK200k 2009
Was it the brake stop light switch (about £12) the one that you replaced , it's the one that's under the steering column ?
 
OP
Blueyes1971

Blueyes1971

Senior Member
Joined
Dec 3, 2010
Messages
238
Reaction score
36
Location
Midlands
Your Mercedes
2002 ML270 CDI Facelift
  • Thread Starter
  • Thread starter
  • #12
Was it the brake stop light switch (about £12) the one that you replaced , it's the one that's under the steering column ?
Yes the brake switch...I have changed between two back and forth
 

Steffen

New Registration
Joined
Jul 17, 2019
Messages
1
Reaction score
0
Your Mercedes
Mb ml 270 2001mod
Hi, i have the same issue as you.
Did you find the problem?
 

Use the code MERCEDES and get 10% MBO Club Discount, oilman's website:www.opieoils.co.uk

register for news and offers email:sales@opieoils.co.ukphone: 01209 202944
Top Bottom