w202 heater controls

japimport

Senior Member
Joined
Feb 19, 2008
Messages
142
Reaction score
0
Location
The Emerald Isle
Your Mercedes
mercedes c200 sport,mercedes c200 elegance
hi there i have a c200 w202,i have aproblem with my heating in my car,the heater blower just blows hot, even when i switch it to cold on the dial,and the centre vent just blows cold all the time,iwent out with the kids on the weekend and we were roasted with the heat,ive no air conditioning,so you can imagine what its like,anyway i would appreciate it if you could point me in the right direction on how to fix it, thanks for your help
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Hell and how are you :D:D this should just be the duo valve needs replacing 115 in this link here
 
OP
japimport

japimport

Senior Member
Joined
Feb 19, 2008
Messages
142
Reaction score
0
Location
The Emerald Isle
Your Mercedes
mercedes c200 sport,mercedes c200 elegance
  • Thread Starter
  • Thread starter
  • #3
lol thanks for the quick response as always malcolm,i really appreciate it,is that part easy to get at,i dont know where the duo valve is located
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Very easy to do,,you will see it and the hoses where they pass through the bulk head into the car.

I think that GSF and euro sell them around £60
 
OP
japimport

japimport

Senior Member
Joined
Feb 19, 2008
Messages
142
Reaction score
0
Location
The Emerald Isle
Your Mercedes
mercedes c200 sport,mercedes c200 elegance
  • Thread Starter
  • Thread starter
  • #5
thats great thanks again
 
OP
japimport

japimport

Senior Member
Joined
Feb 19, 2008
Messages
142
Reaction score
0
Location
The Emerald Isle
Your Mercedes
mercedes c200 sport,mercedes c200 elegance
  • Thread Starter
  • Thread starter
  • #6
just an update ive changed the duo valve,and its still blowing hot air through the vents when the heater controls on cold,anyone have any idea what it could be, thanks in advance
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Oh dear,,this will be the first time that this has not corrected the problem :(

You must measure the voltage going to the duo valve and the should be near enough 12 volts when the controls are set to cold. the center pin is common and the 2 outer ones ar 1 for each valve
 


Text: V4B offer competitive leasing deals across the Mercedes Benz range, we have excellent knowledge and experience on the Mercedes product and we pride ourselves on providing excellent customer service.
V4B
Top Bottom