W210 Starting problems

Wevets

New Member
Joined
Jul 7, 2009
Messages
5
Reaction score
0
Location
Norfolk
Your Mercedes
E280 Avantgarde (W210)
Hi All, although I'm a new kid on the block, I've spent a long time checking posts and haven't come across anyone with this particular problem yet. Any advice would be gratefully received.
I have a 01/97 E280 Avantgarde Saloon. The ignition key is the fold out metal type. Intermitently, when I turn the key in the ignition to start the car, nothing happens. It's as if someone has disconnected the battery. After several attempts, it always starts (so far!). It can happen when the engine's hot or cold. Nothing appears to be loose or broken and it doesn't matter whether I remove the key and reinsert it, or just keep turning it. Although I can live with it, it is at times frustrating / inconvenient / embarrassing and it does seem to be happening more often now.
My DIY knowledge is non-existent and I don't have a money tree! Any suggestions?
Thanks
Steve.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
If the key part turns easily then the ignition switch will need to be replaced, this is a known fault with this switch and worse on the 129
 

xitrum_dalat

Member
Joined
Dec 16, 2008
Messages
20
Reaction score
0
try to check switch gear selector at gear box.
Unplug and clean by contact cleanner.
 
OP
W

Wevets

New Member
Joined
Jul 7, 2009
Messages
5
Reaction score
0
Location
Norfolk
Your Mercedes
E280 Avantgarde (W210)
  • Thread Starter
  • Thread starter
  • #4
Thanks Malcolm, but the key fit is firm and the switch turns to each defined position firmly i.e. with normal resistance. Nothing loose or floppy.
Steve.
 
OP
W

Wevets

New Member
Joined
Jul 7, 2009
Messages
5
Reaction score
0
Location
Norfolk
Your Mercedes
E280 Avantgarde (W210)
  • Thread Starter
  • Thread starter
  • #5
Thanks mate. Looks like a job for the weekend.
Steve.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
If you are turning the key and the dash lights do not come on,then the rear part of the switch needs to be replaced, the key section is OK

Could be a main wire off or loose
 
OP
W

Wevets

New Member
Joined
Jul 7, 2009
Messages
5
Reaction score
0
Location
Norfolk
Your Mercedes
E280 Avantgarde (W210)
  • Thread Starter
  • Thread starter
  • #7
Sorry, bit misleading to say that it was like the battery was disconnected. All the ignition lights and warning lights come on. Everything is as normal except that when you turn the key and hold it at the normal start position i.e. fully clockwise, nothing happens. I do hear what I assume to be the fuel pump kick in if the car has been standing for any length of time, but that's all.
Steve.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Then you do have the alarm, and the gearbox isolator switch, and possibly a K38 protection relay
 

d:class automotive are specialists in automotive interiors and upholstery. From Mercedes and modern cars to custom and classics. Tel: 01483 722923 Email:info@dclass.co.ukWeb:www.dclass.co.uk
Top Bottom