W211 Audio 20 - BT Phone connection.

Damoe

Active Member
Joined
May 11, 2016
Messages
41
Reaction score
11
Location
NI
Your Mercedes
2009 E220 CDI A/Garde W211
Hi,
I have noticed recently that the phone connection can be spotty. It's not the bluetooth connection itself, but rather, at times, the microphone connection is not working, and on one occasion I could not hear the caller.
The phone is definitely connected over BT though as the radio gets muted and the display on both phone and stereo unit says they are connected.
Mostly though, people cannot hear me when I start talking on the phone. They then hang up. Stopping and restarting the stereo can sometimes clear the fault, but usually it takes a turn off of the ignition and a restart, although that doesn't always cure it.

If anyone has any ideas, they would be most appreciated.
 
OP
D

Damoe

Active Member
Joined
May 11, 2016
Messages
41
Reaction score
11
Location
NI
Your Mercedes
2009 E220 CDI A/Garde W211
  • Thread Starter
  • Thread starter
  • #2
No-one?

This is getting more frustrating with the sporadic connection and interface with the phone. With the new law changes being talked about, about even touching your mobile phone while driving, I'm thinking of changing out the head unit....

A bit drastic maybe, but it is so frustrating.

Cheers,
D

PS Looking at other posts where the radio displays the Mercedes logo for ages, mine does that too.

PPS Also today I hit the phone button to call up the last called numbers and the lines of data were a mish mash of special characters etc.

PPPS Reading on about MOST (?) network, will this mean the retrofit of an aftermarket head unit be problematic? Or will it be a plug and play with the correct cables adaptors etc.?
 
Last edited:

d:class automotive are specialists in automotive interiors and upholstery. From Mercedes and modern cars to custom and classics. Tel: 01483 722923 Email:info@dclass.co.ukWeb:www.dclass.co.uk
Top Bottom