W211 E320 Loss of drive

mal-de-merc

New Member
Joined
May 14, 2009
Messages
6
Reaction score
0
Location
North West Lancashire
Your Mercedes
W211 E320 Avantgarde Estate
Joining a motorway, I experienced loss of drive on the entry ramp when kicking-down, which felt like the gearbox had been knocked into neutral. The engine revved but no drive and no malfunctions indicated. I pulled onto the hard shoulder and slowed down and normal drive was restored. The car is a 2004 E320 cdi with 56000 miles on the clock. Since recently getting Superchipped, I have also been experiencing a judder around 40 mph which is not felt through the steering wheel. Any suggestions would be appreciated.
 

carabind

Senior Member
Joined
May 26, 2006
Messages
688
Reaction score
0
Location
Lancashire
Your Mercedes
e class
whats the atf fluid level like ? and has it been changed since new?

Interesting to see the conseuqnece of the "chipping" - have you taken it back yet
 
OP
M

mal-de-merc

New Member
Joined
May 14, 2009
Messages
6
Reaction score
0
Location
North West Lancashire
Your Mercedes
W211 E320 Avantgarde Estate
  • Thread Starter
  • Thread starter
  • #3
I've only had the car since March this year and there's no indication in the Service Record of any ATF change. I assume that the level was checked at last service a few weeks ago.

Went back to Superchipper and was advised that two injectors showing excessive fuel bleed-off and all injectors be ultrasonically cleaned and re-calibrated.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
I cant see how the injectors could cause loss off drive, The gearbox fluid is not part of any service and I doubt that the level was checked
 
OP
M

mal-de-merc

New Member
Joined
May 14, 2009
Messages
6
Reaction score
0
Location
North West Lancashire
Your Mercedes
W211 E320 Avantgarde Estate
  • Thread Starter
  • Thread starter
  • #5
Malcolm

I don't think the injectors and transmission issues are related. My first thought on loss of drive was low ATF level, but I've not had any indication of any loss of ATF. Perhaps it's due an ATF and filter change and although I don't see any reference to this in the Service Book, I've seen other threads discussing an ATF change at 50k miles.

Regards
Malcolm
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
There is nothing to show low fluid,,if it was low then it could starve the pump when accelerating hard or out of a corner

The changing the fluid and filter is something new brought about mainly be forums like this one. It was only ever changed on cars on assyst , once only for life at 40k miles.

Some Dealers still argue over this,,anyway the norm now is every 40-50k miles. Its easy enough to get the level checked
 

star

Forum Supporter
Authorised Forum Supporter
Joined
Oct 6, 2004
Messages
5,875
Reaction score
1,324
Location
Reading
Your Mercedes
Smart + others :)
check the fluid level 1st, if low, i would recommend a filetr change as well. the most common leak is from the connector plug.
 
OP
M

mal-de-merc

New Member
Joined
May 14, 2009
Messages
6
Reaction score
0
Location
North West Lancashire
Your Mercedes
W211 E320 Avantgarde Estate
  • Thread Starter
  • Thread starter
  • #8
Had the level checked by T J O'Neil (Independent Mercedes Workshop in Glasgow) at short notice this morning and gearbox found to be overfull and ATF emulsified. There was also a leak from the electrical connector.
Small amount of oil in radiator expansion tank supported diagnosis that ATF cooling pipe in radiator has failed.

Despite a full workshop diary and one mechanic on holiday, T J O'Neil checked availability of new radiator from MB but price is £579 + VAT so they sourced an OEM radiator for delivery tomorrow and commenced work stripping out radiator and draining gearbox to get the car back on the road so I can get home tomorrow night. Now that's what I call service. Fingers crossed that the gearbox isn't damaged.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Not a Valeo problem then ???
 

turbopete

Senior Member
Joined
Feb 4, 2009
Messages
14,204
Reaction score
328
Age
46
Location
Spennymoor
Your Mercedes
2010 '60' Ford Mondeo 2.0TDCi Zetec (sorry)
sounds awfully similar to me! glad that mines got a behr rad,even though it wasnt affected anyways!
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
40
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
gearbox overfull, with emulsified oil? can only be the rad, and a bad case at that. he even has/had the juddering to go with it.
 


AMF Automotive - We are an independent Mercedes-Benz and AMG specialist located in Dartford, with full Mercedes Diagnostic equipment. We offer a full portfolio of tuning options for AMGs and can cater for all your Mercedes needs.
Tel: 0203 384 4644www.amfmercedes.com/
Top Bottom