1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

W211 washers stopped working Help please

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by janusrolex99, Jan 11, 2019.

  1. janusrolex99

    janusrolex99 Senior Member

    Messages:
    51
    Likes Received:
    0
    Joined:
    Oct 4, 2015
    Location:
    Rye
    Your Mercedes:
    2012 E350 sport estate 265 bhp
    Hi. My 2008 e320 estates washers have stopped working and caused an MOT to fail.
    The pump is working ok and the water is pumping up to both jets. But nothing comes out of either jet! Its as if they have somehow shut down. Tried clearing the jets with the appropriate tool and also blowing through with an airline. Really got me puzzled. Any help greatly appreciated.
     
  2. bembo449

    bembo449 Senior Member

    Messages:
    2,828
    Likes Received:
    538
    Joined:
    Jan 2, 2012
    Location:
    lincolnshire
    Your Mercedes:
    w221 320cdi , r170 23k , range rover vogue , insignia vxr , shitron dispatch
    have these got the lil ball bearing that blows out when they get blocked ?
     
  3. OP
    janusrolex99

    janusrolex99 Senior Member

    Messages:
    51
    Likes Received:
    0
    Joined:
    Oct 4, 2015
    Location:
    Rye
    Your Mercedes:
    2012 E350 sport estate 265 bhp
  4. OP
    janusrolex99

    janusrolex99 Senior Member

    Messages:
    51
    Likes Received:
    0
    Joined:
    Oct 4, 2015
    Location:
    Rye
    Your Mercedes:
    2012 E350 sport estate 265 bhp
  5. Craiglxviii

    Craiglxviii Senior Member

    Messages:
    13,502
    Likes Received:
    3,041
    Joined:
    Sep 6, 2015
    Location:
    Cambs UK
    Your Mercedes:
    W215 CL500 Motorway Queen; W251 R320L Familybenz, S211 E320 Avg Designo Edition now sadly missed.
    No, just simple fluidic jets on a 211.
     
  6. OP
    janusrolex99

    janusrolex99 Senior Member

    Messages:
    51
    Likes Received:
    0
    Joined:
    Oct 4, 2015
    Location:
    Rye
    Your Mercedes:
    2012 E350 sport estate 265 bhp
    Have you any idea why they would have stopped spraying when water is pumped well up to them?
     
  7. OP
    janusrolex99

    janusrolex99 Senior Member

    Messages:
    51
    Likes Received:
    0
    Joined:
    Oct 4, 2015
    Location:
    Rye
    Your Mercedes:
    2012 E350 sport estate 265 bhp
    I have no idea. It’s as if they shut off. I don’t suppose the power to the jets could be a factor?
     
  8. alexanderfoti

    alexanderfoti MBO Forum Supporter Authorised Forum Supporter

    Messages:
    10,812
    Likes Received:
    1,435
    Joined:
    Mar 25, 2010
    Location:
    Dartford
    Your Mercedes:
    W221 S65 AMG - W204 C63 AMG + Various other MB's
    The power to the jets is for the heating in them.

    IF you disconnect the pipe from the pump and actuate it, do you get a good flow from the pump?

    Likewise, when you blow an air line through the jets, do you actually get air from the other end?
     
    Blobcat likes this.
  9. umblecumbuz

    umblecumbuz Senior Member

    Messages:
    3,380
    Likes Received:
    706
    Joined:
    Sep 20, 2010
    Location:
    Wales and Gozo
    Your Mercedes:
    S204 and CLC 204 cdi, other non-Merc machines
    Which way did you blow? Through the jet down to the pump, or the other way around?
    If you did the first - which is the best way to dislodge any deposits, short of removing the jets themselves - you need to unclip the line at the pump end before doing so.

    It also pays dividends to filter any topup liquid through a fine strainer when refilling the reservoir. Maybe any previous owner has failed to do this and you're now paying the price.
     

Share This Page