W220 Comand Gremlins

Owletend

New Member
Joined
Feb 27, 2009
Messages
5
Reaction score
0
Your Mercedes
S500
I have a MY1999 S500 which is bloomin' marvellous, but she does have one idiosyncracy which I'd like to resolve.

She is quite a high spec car and cost someone a lot of money when she was new. Everything on her works most of the time, but there are occasions when the Comand system becomes temperamental. What happens is, the system will be working fine, then with a slight crackle through the speakers the sound will go. Generally at the same time the system will suddenly decide it doesn't have a CD player or a phone, but it does still have a tape player, a radio, and a nav system. In other words the head unit has lost communication with the other units in the car, including the amplifier. I have had the head unit overhauled and I don't believe it is the culprit; it communicates with the dash display whatever is happening and seems to be doing what it should. I suspect there is either a wiring problem in the car and/or there is a central computer/switching device somewhere which needs overhauling or replacing. Before I give up and take it to the dealer does anyone have previous experience of this type of problem and if so can you give me a clue as to where I might focus my efforts to fix this? All suggestions gratefully received.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Hello and welcome.. the circuit is known as the D2b and is an optical system that couples all the units together,,if a connector is loose or may be damaged,then it will loose contact with the other components on the car. By removing an optic cable and the system is turned on, there should be a red light showing in the end of the optic cable and one in the socket,,the phone,CD changer,Amp all have one. these fiber optic cables form a ring,,if the ring is broken,then nothing will work other than the navigation.

Owing to the dismantling it could be easier to find a good indie with STAR and this could pin point the fault

Welcome to the forum
 
OP
O

Owletend

New Member
Joined
Feb 27, 2009
Messages
5
Reaction score
0
Your Mercedes
S500
  • Thread Starter
  • Thread starter
  • #3
Thanks, I've read a bit about the optical circuit and thought it might be that. I also thought it might be connectors but when poking around have so far concentrated on the wiring connectors rather than the optical ones.

Is there a listing somewhere on the site of independant garages that have been used and are recommended by others?

Andrew
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Where are you in the UK Andrew
 
OP
O

Owletend

New Member
Joined
Feb 27, 2009
Messages
5
Reaction score
0
Your Mercedes
S500
  • Thread Starter
  • Thread starter
  • #5
Stratford-upon-Avon, so garages in Warwickshire ideally or in the Midlands.

Thanks.
 
OP
O

Owletend

New Member
Joined
Feb 27, 2009
Messages
5
Reaction score
0
Your Mercedes
S500
  • Thread Starter
  • Thread starter
  • #7
Thanks, will do.

Andrew
 
Top Bottom