1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

W221 CDI Limp Mode

Discussion in 'Engine, Drivetrain, Fuel and Exhaust' started by gilbert121262, Nov 28, 2012.

  1. gilbert121262

    gilbert121262 Senior Member

    Messages:
    119
    Likes Received:
    0
    Joined:
    Dec 20, 2007
    Your Mercedes:
    s350cdiL w221
    If you look through my past posts you will see that I have had problems with limp mode before. Had EGR Valve changed in Mar this year then IPS motor. All has been well until last week. Car went into limp mode 3 times in one day. Took it to indie who found following faults, EGR Valve IPS Motor and a sensor that I cant remember. He did say that it could be clogged up again as I spend a lot of time in London and it had’nt had a blast for a few weeks. Booked it in for service as due in 1800 miles anyway. Decided to keep it in S mode instead of C. Following day put it into C got the hump with the sport suspension setting. Turned car off for 15 mins got back in it and straight into limp mode. Turned off an on again all well so left in S mode. Had it serviced yesterday including air filters as clogged again, they never last for 2 services and fuel filter. Car fine last night when I picked it up fast and responsive. This morning all well when started it. Stopped after 15 mins to put a letter in post box, did’nt turn it off but when I got back in it got the distinctive clonk when put into drive that means it in limp mode again. Had just put back into c mode prior to stopping. Turned off and on all well again. Stopped car after 10 mins and started all well still. The next start it was in limp mode but engine light on now!!!. Took it back to be plugged in and this time EGR Valve air mass to low. Cleared fault and he said it could be one of the MAF’s but as they about £300 not sure what route to go down. Car alright this afternoon right up until I put it into C mode, 20 secs later limp mode again. Is this a coincidence or is moving it from s to c mode causing the problem. Any thought welcome.
     
  2. WG M-B

    WG M-B Senior Member Authorised Forum Supporter

    Messages:
    3,105
    Likes Received:
    6
    Joined:
    Dec 5, 2010
    Location:
    North west london
    Your Mercedes:
    C63 Wagon in black
    Nothing springs to mind on this one. Maybe someone else should take a look for you. Possibly blocked exhaust???
    The mafs are part of the air trunking
     
  3. Steve@Avantgarde

    Steve@Avantgarde Forum Supporter Authorised Forum Supporter

    Messages:
    6,825
    Likes Received:
    1,003
    Joined:
    Dec 8, 2009
    Location:
    Bristol/Somerset
    Your Mercedes:
    C220CDI AMG Line Premium, SLR McLaren Roadster, SL55 & C32AMG
    The MAFs can be tested on STAR to see if they are measuring correctly. You say you used an Indie, but was it a proper indie with STAR diagnosis?

    It could be you have the MAF fault code there as the engine ECU will use the MAF to put the engine into limp mode, common error made by some thinking its a MAF issue.

    Have the air filters been replaced and the engine ECU been reprogrammed? That will throw up an engine light and limp mode if they have not been done/done properly! I have to be honest, I dont think I have replaced a MAF on this engine for poor running yet, they tend to be fine.
     
  4. OP
    gilbert121262

    gilbert121262 Senior Member

    Messages:
    119
    Likes Received:
    0
    Joined:
    Dec 20, 2007
    Your Mercedes:
    s350cdiL w221
    Thanks for your replies. The air filters have been replaced and he did reset ECU after they were done. He an ex merc man and seems to know his stuff but I dont think he has a star machine just a generic one. Anyone recomend someone in the surrey kent area that has proper star diagnostics. Look forward to a reply.
     
  5. Steve@Avantgarde

    Steve@Avantgarde Forum Supporter Authorised Forum Supporter

    Messages:
    6,825
    Likes Received:
    1,003
    Joined:
    Dec 8, 2009
    Location:
    Bristol/Somerset
    Your Mercedes:
    C220CDI AMG Line Premium, SLR McLaren Roadster, SL55 & C32AMG
    If you are Surrey way then Ian at STAR motor services is your man, hes in Caversham.
     
  6. toby1

    toby1 Senior Member

    Messages:
    4,901
    Likes Received:
    170
    Joined:
    Mar 13, 2007
    Location:
    West Berkshire
    Your Mercedes:
    1998 CL420 C140
    Berkshire could be a bit of a mission though depending on the OP's location.
     
  7. OP
    gilbert121262

    gilbert121262 Senior Member

    Messages:
    119
    Likes Received:
    0
    Joined:
    Dec 20, 2007
    Your Mercedes:
    s350cdiL w221
    I'm in the surrey kent border so reading bit of a mission, thanks anyway.
     
  8. st4

    st4 Banned

    Messages:
    8,624
    Likes Received:
    2
    Joined:
    Apr 6, 2008
    Location:
    Sunny Scotland
    Your Mercedes:
    Disqualified driver
    Sounds like the manifold is gunked up and the swirl flap mechanism cannot operate as the manifolds are caked up with crap from the EGR. This would cause the flaps to default to closed reducing power drastically.

    You need to get the linkages from the IPS to the swirl flaps checked and the manifold cleaned or replaced.
     
    Last edited: Dec 1, 2012
  9. OP
    gilbert121262

    gilbert121262 Senior Member

    Messages:
    119
    Likes Received:
    0
    Joined:
    Dec 20, 2007
    Your Mercedes:
    s350cdiL w221
    This is going to be shot down in flames as me clutching at straws, but bear with me. The first time my car went into limp mode after haveing Inlet port shutoff motor replaced, was in October. I remember it well because I was on blackfriars bridge 6pm thursday night in a torrential rainstorm. Then 2 weeks ago it started doing it again. I checked my credit card statements and every time it had gone into limp mode I had put esso diesel in. I only use esso or shell fuel due to garages on my route home. If I had put shell in no limp mode. Think I might open a can of worms with this statement but dates and limp mode occurences all match up. 60 litres of shell v power diesel put in today, will keep you informed.
    Sure I will get some input on this one!!!!!
     
  10. Steve@Avantgarde

    Steve@Avantgarde Forum Supporter Authorised Forum Supporter

    Messages:
    6,825
    Likes Received:
    1,003
    Joined:
    Dec 8, 2009
    Location:
    Bristol/Somerset
    Your Mercedes:
    C220CDI AMG Line Premium, SLR McLaren Roadster, SL55 & C32AMG
    We await with interest......
     
  11. st4

    st4 Banned

    Messages:
    8,624
    Likes Received:
    2
    Joined:
    Apr 6, 2008
    Location:
    Sunny Scotland
    Your Mercedes:
    Disqualified driver
    Run some millers diesel eco max in the tank
     
  12. OP
    gilbert121262

    gilbert121262 Senior Member

    Messages:
    119
    Likes Received:
    0
    Joined:
    Dec 20, 2007
    Your Mercedes:
    s350cdiL w221
    was talking bo**ocks again. Inlet port shut off motor gone again. Lasted 10k miles, excellent!!!!!
     

Share This Page