1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Washer problems clk

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by Davepil, Nov 10, 2012.

  1. Davepil

    Davepil Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    Nov 3, 2012
    Location:
    Wigan
    Your Mercedes:
    Clk240/2003/2.6
    Still having problems with my windscreen washer, pump is ok, but when stalk is depressed nothing happens, no sound or movement from the wipers. Also my headlamp washers aren't working! Anyone got any ideas
     
    Last edited: Nov 10, 2012
  2. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    277
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    This fault is often the stalk, , but I take it the washer for headlamps is on a different switch, have the pumps been checked
     
    Last edited: Nov 10, 2012
  3. OP
    Davepil

    Davepil Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    Nov 3, 2012
    Location:
    Wigan
    Your Mercedes:
    Clk240/2003/2.6
    yes, changed the pump,thinking that was the problem, but no change, have now tested pump and it works, but when you press the stalk the wipers don't work although everything else on the stalk works
     
  4. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    277
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    The pumps are inductive loads and these can burn the switch contacts to a point where they will not function,,, the stalk is the most common failure
     
  5. OP
    Davepil

    Davepil Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    Nov 3, 2012
    Location:
    Wigan
    Your Mercedes:
    Clk240/2003/2.6
    would I have to change the whole stalk or can it be repaired, also the headlamp washers are a separate switch, would this be a separate problem
     
  6. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    277
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    More than likely yes a separate fault, some have managed to remove the end cap and let switch cleaner run down the tube, it is a steering wheel off job to get to the actual switch,,,I might have a 202 circuit that could be the same
     
  7. OP
    Davepil

    Davepil Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    Nov 3, 2012
    Location:
    Wigan
    Your Mercedes:
    Clk240/2003/2.6
    how woulld i get the end cap off
     
  8. rf065

    rf065 Senior Member

    Messages:
    2,683
    Likes Received:
    178
    Joined:
    May 30, 2007
    Location:
    Grossbritannien
    Your Mercedes:
    SLC300 - C250d Estate 4 Matic & Z900rs
    I would treat this as two different faults for now. If it's any help I've had to replace the stalk on mine as the wipers would only work if you fiddled about with the switch.

    Also, my headlight washers would not work, until I noticed they would only work after a really long run. Not sure if it's a voltage problem & a really good charge is needed, but I use them more often now & they seem to be OK.

    Malcolm did send me a paper on the CLK headlight washers that required a resistor to be fitted to get them to work, I'll see if I've still got it unless Malcolm has it to hand?

    Russ
     
    Last edited: Nov 10, 2012
  9. OP
    Davepil

    Davepil Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    Nov 3, 2012
    Location:
    Wigan
    Your Mercedes:
    Clk240/2003/2.6
    thanks, do you know if I can get the end off the stalk
     
  10. rf065

    rf065 Senior Member

    Messages:
    2,683
    Likes Received:
    178
    Joined:
    May 30, 2007
    Location:
    Grossbritannien
    Your Mercedes:
    SLC300 - C250d Estate 4 Matic & Z900rs
    It is only a press fit and can be removed with care, spraying cleaner down mine did not help and I dismantled it further. This led to many springs and small plastic parts exploding all over the inside of the car. I managed to find them all but could not get them back in place as intended, ended up just replacing the stalk.

    Russ
     
    Last edited: Nov 10, 2012

Share This Page