wiper / washer inop 2013 C350 30k miles

pomm001

Senior Member
Joined
Nov 9, 2006
Messages
407
Reaction score
2
Location
leicester
Your Mercedes
SLK 5.5 A 140
Here's an odd
I took my C350 out of the garage recently to clean my garage up, and parked it on my drive the bonnet was not fully latched as just topped up the washer
When i came to put it back the wiper did a sweep and stopped when not fully in its park position
a few seconds later it slowly moved to its parked position.
Trying the wipers later neither the wipers or the washers work, thinking it may be a fuse i looked at the fuse layout as per the diagram now with the spare wheel and not in the handbook ( that's handy, not )
Wipers and washers are controlled by fuse # 10 which is a 30 amp and 13 which is a 7.5 amp
checked both fuses for continuity with the meter, both OK, both showing battery voltage either side of the fuse when in situ.
Well now i'm stuck, is there a relay contolling the wiper motor, if so anyone have an idea where it may be
Many thanks
 
OP
pomm001

pomm001

Senior Member
Joined
Nov 9, 2006
Messages
407
Reaction score
2
Location
leicester
Your Mercedes
SLK 5.5 A 140
  • Thread Starter
  • Thread starter
  • #2
After a lot of head scratching, disconnecting the battery and 're boot' that didn't make any difference
Out of desperation i sprayed WD down both sides of the bonnet catch locks ( which were greased) and slammed the bonnet shut
.......... everything works fine again
If you have a W204 worthwhile giving the catches a spray of WD 40 as the micro switch/s overrides many systems including the ECO
 

WE HAVE NOW MOVED: 8 Hazel Road, Woolston, SO19 7GB
Service, Repairs and remapping service
Any queries, please do not hesitate to contactEmail@mbsofsouthampton.co.ukor alternatively you can phone Colin or Dave on 02380 445820, out of hours numbers are 07787913313 or 07907631681.
Top Bottom