1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Wonder if anyone can help

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by schooner, Nov 23, 2012.

  1. schooner

    schooner Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    Sep 3, 2012
    Your Mercedes:
    c180
    I have a C180 W203, today I have had an MOT, on pick up the engine management light is now on,which was not on before the MOT.
    I took it back,where they made attempts to turn it off,with no luck,they assure me they they havent touched anything that would have caused this.
    Does anyone know if during an MOT they touch anything that will cause the engine management light to come on.
     
  2. mercmancdi

    mercmancdi Senior Member

    Messages:
    3,254
    Likes Received:
    700
    Joined:
    Dec 6, 2011
    Location:
    templepatrick - co antrim
    Your Mercedes:
    2009 E250 cdi 08 cls320 cdi ,2007 e280 cdi '2005 E 280 CDI ,VW TOUAREG ,JAGUAR S AND xTO NAME A FEW
    No expert but been through many m o ts and can't see how they should have any need to do anything to bring light on.

    Would be interested in hearing what caused it when you sort it.
     
    Last edited: Nov 23, 2012
  3. isargas

    isargas New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Sep 17, 2010
    Your Mercedes:
    200/2004/1800
    Crankcase breather hose

    I had exactly the same happen to me. I reset the light, then a few days it came back on, so I reset again. Warning was "No 1 spark plug misfire". I changed the plugs, they were about 20000 miles old. Warning light stayed off for weeks, then came on.All I read seemed to point to dirty mass air flow meter, so set off to clean it. Removed air filter housing and found problem - there is a small crankcase breather hose under the filter, and this had been rubbing for 9 years and so had a small hole in it. Replaced it £10, all sorted!
     

    Attached Files:

    • hose.jpg
      hose.jpg
      File size:
      172.5 KB
      Views:
      14
    Last edited: Jan 2, 2013
  4. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    310
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    Cars can be left with the engine running for a very long time while being tested. A lively drive often turn the lamps off again if the car drives just fine
     
  5. CITYBOY

    CITYBOY Senior Member

    Messages:
    321
    Likes Received:
    2
    Joined:
    Oct 18, 2010
    Location:
    Cheshire
    Your Mercedes:
    C Class C180 Blueeffiffiency 1.8 W204 {2012}
    Thats interesting regarding the air filter housing,and the hose leak under it,are you talking about a W203 c180,and is the housing you refer to,at top right hand side of engine compartment,as you face it from front of car.
     
  6. Rappey69

    Rappey69 Senior Member

    Messages:
    1,894
    Likes Received:
    382
    Joined:
    Dec 29, 2008
    Location:
    hants
    Your Mercedes:
    c220 w204 amg sport
    Aint that the truth.. Took my brothers renault laguna with 50k for mot other day.
    12 mile drive there plus 5 miles at 70mph.
    Emission readings were off the scale...engine management light should have been on.
    Garage suggested it may have been sat for a while so take it for a thrash around the block to get it very hot.. I did that and readings dropped to a passable level...
     

Share This Page