1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

S210 not crank, even replacing battery...

Discussion in 'General Mercedes-Benz Related Discussion' started by Linuus, Feb 8, 2018.

  1. bob 6600

    bob 6600 Senior Member

    Messages:
    2,118
    Likes Received:
    181
    Joined:
    Dec 21, 2010
    Your Mercedes:
    S210 E320 CDI
    Yep 2000 S210 E320 CDI AG
     
    Linuus likes this.
  2. bob 6600

    bob 6600 Senior Member

    Messages:
    2,118
    Likes Received:
    181
    Joined:
    Dec 21, 2010
    Your Mercedes:
    S210 E320 CDI
    Have a word with @om613 he may have some parts
     
    om613 and Linuus like this.
  3. ajlsl600

    ajlsl600 Senior Member

    Messages:
    1,688
    Likes Received:
    299
    Joined:
    Nov 18, 2013
    Location:
    france
    Your Mercedes:
    clk3202001,sl6002003 with everything,A class 170cdi auto
    i have had a good number of incidents where the starter stops in one place and is then lazy or wont turn on restart attempt sometimes a partial turn has it working again ,if so only fix is replacement . but for sure every reason to interview starter and learn something,if its not exchange unit.
     
    Linuus likes this.
  4. OP
    Linuus

    Linuus Senior Member

    Messages:
    201
    Likes Received:
    56
    Joined:
    Dec 5, 2017
    Location:
    crawley
    Your Mercedes:
    w210 wagon
    Will need to investigate why mine is 15A... :/ I can’t find any schematics for that k40


    Sent from my iPhone using Tapatalk
     
  5. om613

    om613 Senior Member

    Messages:
    1,165
    Likes Received:
    208
    Joined:
    Aug 29, 2015
    Location:
    london
    Your Mercedes:
    S202 C250TD, S123 240TD
    I had that non-start thing once ... not since the battery was changed.
     
  6. OP
    Linuus

    Linuus Senior Member

    Messages:
    201
    Likes Received:
    56
    Joined:
    Dec 5, 2017
    Location:
    crawley
    Your Mercedes:
    w210 wagon
    in my case I had a jump start, didn't work, so I bought a new battery didn't work, so with help the forum I looked close into the k40 module relay and circuit board and the track was burnt. so I've done a "bridge" to connect from pin point A to pin point B with a small wire and from that moment I could hear the relay clicking, and then, me and my friend moved forward to the starter and we saw current on the starter but the motor doesn't want to work so, I am waiting for a new starter to be then install as well the k40 module everything should arrive by Tuesday. and hopefully the issue will be sorted... other wise, I will need to take him into a MB specialist...
     
  7. bob 6600

    bob 6600 Senior Member

    Messages:
    2,118
    Likes Received:
    181
    Joined:
    Dec 21, 2010
    Your Mercedes:
    S210 E320 CDI
    Linuus likes this.
  8. OP
    Linuus

    Linuus Senior Member

    Messages:
    201
    Likes Received:
    56
    Joined:
    Dec 5, 2017
    Location:
    crawley
    Your Mercedes:
    w210 wagon
    So I’ve order secund hand k40 relay but it’s diferente from the one in my car I just have notice that my one has 2 holes close to the part number and a number 053761(20) and the one I’ve order has a number 053761(00) so I guess better not to try not to mess around with the electric... here the picture from mine inside the car and the one I bought.. [​IMG][​IMG][​IMG][​IMG]
    What do I do now?!


    Sent from my iPhone using Tapatalk
     
  9. bob 6600

    bob 6600 Senior Member

    Messages:
    2,118
    Likes Received:
    181
    Joined:
    Dec 21, 2010
    Your Mercedes:
    S210 E320 CDI
    You should really get one with the same part number. It's stamped on the part
     
    Linuus likes this.
  10. OP
    Linuus

    Linuus Senior Member

    Messages:
    201
    Likes Received:
    56
    Joined:
    Dec 5, 2017
    Location:
    crawley
    Your Mercedes:
    w210 wagon
    Just bought the correct one now!!! Need to be this one, because MB wants 87£ for it... -.-“


    Sent from my iPhone using Tapatalk
     
  11. OP
    Linuus

    Linuus Senior Member

    Messages:
    201
    Likes Received:
    56
    Joined:
    Dec 5, 2017
    Location:
    crawley
    Your Mercedes:
    w210 wagon
    [SOLVED] So, just to close this thread, I can confirm the starter was bad, replaced, with a new one, old k40 still working with the bridge I’ve done. But I have a new one to install next day off. Just done one thing, be careful with disconnecting battery. Now need to enter radio code and reset all windows, that what I have notice so far from disconnecting the battery right guys? Or is there any gremlins I shall be aware of... thanks


    Sent from my iPhone using Tapatalk
     
    om613 likes this.
  12. LostKiwi

    LostKiwi Senior Member

    Messages:
    12,177
    Likes Received:
    4,221
    Joined:
    Aug 25, 2006
    Location:
    Midlands / Charente-Maritime
    Your Mercedes:
    '93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
    Good result in the end!
     
    Linuus likes this.
  13. OP
    Linuus

    Linuus Senior Member

    Messages:
    201
    Likes Received:
    56
    Joined:
    Dec 5, 2017
    Location:
    crawley
    Your Mercedes:
    w210 wagon
    Once again thank you so much for you help and knowledge, and all the forum too.


    Sent from my iPhone using Tapatalk
     
    LostKiwi likes this.
  14. bob 6600

    bob 6600 Senior Member

    Messages:
    2,118
    Likes Received:
    181
    Joined:
    Dec 21, 2010
    Your Mercedes:
    S210 E320 CDI
    You will have got BAS ABS errors too, just turn steering from lock to lock and they will disappear
     
    Linuus likes this.
  15. OP
    Linuus

    Linuus Senior Member

    Messages:
    201
    Likes Received:
    56
    Joined:
    Dec 5, 2017
    Location:
    crawley
    Your Mercedes:
    w210 wagon
    Nice @bob6600 will to that. Yesterday done all windows and sunroof “tuning” and radio was skipping from CDC to radio and vice versa, don’t know if that anything to do with the battery disconnection


    Sent from my iPhone using Tapatalk
     
  16. ajlsl600

    ajlsl600 Senior Member

    Messages:
    1,688
    Likes Received:
    299
    Joined:
    Nov 18, 2013
    Location:
    france
    Your Mercedes:
    clk3202001,sl6002003 with everything,A class 170cdi auto
    yr the go to man for all the gen ref that issue for a while .....!! would say starter had something to do wid yr fried board.tho would also have thought fuse there to prevent that...
     
    Linuus likes this.

Share This Page