1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

W202 lost all stalk functions then came back

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by EdGasket, Jun 13, 2018.

  1. EdGasket

    EdGasket Senior Member

    Messages:
    358
    Likes Received:
    5
    Joined:
    Jan 12, 2012
    Location:
    UK
    Your Mercedes:
    C180 Esprit 1999
    Started off and found washers and wipers were not functioning; I think direction indicators had also stopped working. Turned round to come back home but after about half a mile they all were working again. I think it is something like a corroded contact as the car is nearly 20 years old but where would I look? Is there a relay or somehting like that to check?
     
  2. John Laidlaw

    John Laidlaw Senior Member

    Messages:
    15,910
    Likes Received:
    3,561
    Joined:
    Nov 15, 2013
    Location:
    Wirral
    Your Mercedes:
    W212 E63 ///AMG V8 Biturbo Volvo XC90 2018
    Check your fuse boxes themselves, might be some corrosion around them causing all sorts of gremlins (ask me how I know....)
     
  3. OP
    EdGasket

    EdGasket Senior Member

    Messages:
    358
    Likes Received:
    5
    Joined:
    Jan 12, 2012
    Location:
    UK
    Your Mercedes:
    C180 Esprit 1999
    There were some oxidised fuses in the section with the two yellow wiper relays; maybe that was it. The relay contacts looked OK.
     
    John Laidlaw likes this.
  4. LostKiwi

    LostKiwi Senior Member

    Messages:
    13,774
    Likes Received:
    5,201
    Joined:
    Aug 25, 2006
    Location:
    Midlands / Charente-Maritime
    Your Mercedes:
    '93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
    If the fuses are this type
    [​IMG]
    do yourself a favour and bin the lot of them and replace with new brass style ones (as in the rightmost one in the pic) .
    You should be able to get them from any decent boat chandlers.
     
    John Laidlaw likes this.
  5. OP
    EdGasket

    EdGasket Senior Member

    Messages:
    358
    Likes Received:
    5
    Joined:
    Jan 12, 2012
    Location:
    UK
    Your Mercedes:
    C180 Esprit 1999
    No they are the blade type
     
  6. LostKiwi

    LostKiwi Senior Member

    Messages:
    13,774
    Likes Received:
    5,201
    Joined:
    Aug 25, 2006
    Location:
    Midlands / Charente-Maritime
    Your Mercedes:
    '93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
    Well that should be a relief for you. The other type are carp!
     
  7. EmilysDad

    EmilysDad Senior Member

    Messages:
    6,291
    Likes Received:
    661
    Joined:
    May 8, 2012
    Location:
    Bury Lancs
    Your Mercedes:
    R320 2007
    Phew! The last car I saw those (bullet fuses) in was my Dad's MKII Granada :)
     
  8. LostKiwi

    LostKiwi Senior Member

    Messages:
    13,774
    Likes Received:
    5,201
    Joined:
    Aug 25, 2006
    Location:
    Midlands / Charente-Maritime
    Your Mercedes:
    '93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
    My 129 has the hateful things...
     
  9. Naraic

    Naraic Moderator

    Messages:
    9,794
    Likes Received:
    604
    Joined:
    Mar 4, 2010
    Your Mercedes:
    2005 CL500.
    The 202 has black oblong relay (could be K40)...this is associated with what you describe.
     
  10. OP
    EdGasket

    EdGasket Senior Member

    Messages:
    358
    Likes Received:
    5
    Joined:
    Jan 12, 2012
    Location:
    UK
    Your Mercedes:
    C180 Esprit 1999
    Its been OK since I cleaned the fuses but just in case, where is the relay you refer to? Is it in the same part of the fuse box as the two yellow ones associated with the wipers?
     

Share This Page