1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

W221 s350 bluetec adblue eml issue

Discussion in 'Engine, Drivetrain, Fuel and Exhaust' started by alex_78, Apr 14, 2018.

  1. alex_78

    alex_78 Senior Member

    Messages:
    58
    Likes Received:
    6
    Joined:
    Mar 6, 2017
    Location:
    edinburgh
    Your Mercedes:
    w221/2011/s350
    hi again

    after few weeks of problem free relationship with my s class he reminds me that it will be not easy life...

    in past i add adblue few times it was always same "procedure" check engine on and message adblue by workshop etc
    so first time i add 20 liters and warning light goes off
    some time later light again i add 10 liters and all good

    yesterday i had check engine light and adblue message
    i was next to halfords so bought 10 liters light go off but check engine goes back later with same error so i bought another 10 liters in bp garage put it in
    as results was driving car for less than 100 miles i have 3 or 4 times message to ad blue ( which already add 20 liters) and check engine (EML) play funny go on and off sometimes is on for few minutes then disappear for minute or so.

    can drive normal no limp mode etc good power and fast response etc

    also i think is smell less "vinegear silicone" from exhaust is possible that fuse on pump of adblue fails etc?

    or is any other way to cancel ad blue message any sensor there etc ? in past was going ok itself and is first time when play funny way

    i check codes i have 2:

    P2BA8 - which can be costly sensor but in past this code come on when adblue run out and clear after topup but now when i erase it it goes back i guess something stuck and car "think is still no adblue
    P2047 - i was google that and it can be few things most common fuel filter (i will replace it after weekend) or this code can be triggered by code above coz i notice sometimes errors works as chain reaction?

    main question is which fuse i need to check for adblue pump and is any way to reset adblue level without STAR i have basic code reader only

    thanks
     
  2. OP
    alex_78

    alex_78 Senior Member

    Messages:
    58
    Likes Received:
    6
    Joined:
    Mar 6, 2017
    Location:
    edinburgh
    Your Mercedes:
    w221/2011/s350
    I add another 5 liters so tank is full

    Check engine still go on and off but only show first code
    Also add adbluevshows once

    Is any way to reset it?

    How car check level of adblue?

    Anyone have any expierence with that?
     
  3. Headhurts

    Headhurts Senior Member

    Messages:
    732
    Likes Received:
    154
    Joined:
    Jul 24, 2014
    Location:
    Norwich, Norfolk
    Your Mercedes:
    E350 Night Edition Estate/2016/Diesel
    When I collected my car newfrom dealership I had the Adblue warning come up 2 miles from dealership I returned but they could not trace the problem immediately.

    The Adblue was drained and replaced I believe a sensor on the exhaust was replaced.

    The car had to go back in a couple of days later for them to trace the initial problem.

    It turned out to be the sensor in the Adblue tank it needed to be recalibrated.

    Yours could simply need calibration.

    Feel free to ignore me as I know nothing.

    Robin
     
  4. OP
    alex_78

    alex_78 Senior Member

    Messages:
    58
    Likes Received:
    6
    Joined:
    Mar 6, 2017
    Location:
    edinburgh
    Your Mercedes:
    w221/2011/s350
    thanks Robin
    that make sense it must be calibrated or reset

    current status:
    -adblue tank full
    -check engine on with both codes as above
    -it was message that after 482 miles engine start will be impossible (i manage to reset/delete this following youtube guide)

    from my point of view blutec/adblue system is not working
    i don't smell specific "perfume" from exhaust ;)
    also when it was working it was clicking noise but is not now

    it looks like it need to be reset or calibrated

    anyone have any experience with this ?

    is any diy method or it must be STAR?

    i try to avoid dealer coz of cost and time also don't have to good experience with indy so that is last resort...
     
  5. Botus

    Botus Senior Member

    Messages:
    2,124
    Likes Received:
    212
    Joined:
    Jul 29, 2014
    Location:
    UK
    Your Mercedes:
    S500/2010/500
    u can ignore me too as I know nothing.
    but my first port of call to add new and how, if required to reset messages would be the owners manual.

    some bodge on youtube sounds a great way to get it wrong
     
  6. OP
    alex_78

    alex_78 Senior Member

    Messages:
    58
    Likes Received:
    6
    Joined:
    Mar 6, 2017
    Location:
    edinburgh
    Your Mercedes:
    w221/2011/s350
    yes i was reading owners manual and check youtube

    for that reason message is deleted

    according to owner manual adblue should be top up by specialist garage slightly to late for it coz i bought and put it in already and tank is full (in past that was ok)

    current problem is that looks like system not working and not reset itself like in past (no specific smell and no clicks sound)

    as was mentioned above looks like need recalibration/reset etc i check all resources online but before i go to dealership and pay £90 for 2 mins job on STAR i was hoping to find solution on my favourite help full and friendly forum ;)
     
  7. Botus

    Botus Senior Member

    Messages:
    2,124
    Likes Received:
    212
    Joined:
    Jul 29, 2014
    Location:
    UK
    Your Mercedes:
    S500/2010/500
    look for a good independent garage with ideally a recco from here.

    main dealers (all brands) are just marketing specialist with kwik fit fitter animals in the workshops.... they tend to know less about cars or how to fix them than a tennis racket
     
  8. OP
    alex_78

    alex_78 Senior Member

    Messages:
    58
    Likes Received:
    6
    Joined:
    Mar 6, 2017
    Location:
    edinburgh
    Your Mercedes:
    w221/2011/s350
    problem is that i can't find decent indy

    what i try so far or charge almost the same money as dealer and most of them are great specialist to change oil and charge £200 for labour but more complex issues they either don't know what to do or change parts but without solution...

    for that reason i start fix car myself and so far all what i done myself is works as should including oil cooler seal, turbo seal, knocks from suspension....

    in that case i can't fix it myself coz i don't have STAR

    coz it looks clearly like electronic glitch and should be fixed by calibrating reseting sensor in adblue tank coz tank is full but car "thinks" is empty and still shows message to fill it

    i read on one page from usa that every few fills up of adblue sensor should be calibrated as Robin mentioned above.

    i decide go to dealer (book it already) i see how this ends up with them....
     
  9. Botus

    Botus Senior Member

    Messages:
    2,124
    Likes Received:
    212
    Joined:
    Jul 29, 2014
    Location:
    UK
    Your Mercedes:
    S500/2010/500
    good luck, might get some software tweaks it always needed (that's one downside to indies.....)

    every one thinks the hideous badly written junk software a car stated life with is good enough for the next 10 years.... its always rushed out to get the vehicle on the road to make money not cos the engineers where happy)

    here's some rambling and interesting video on BM bike's software...

    .... I've been checking out software updates

    oddly looks like most of the time when BM are updating vehicle electronic modules they miss out the ABS module. Not sure why, in this video I thought he didn't have ABS now not so sure after watching others, its of a bloke doing it himself at home

    https://www.youtube.com/watch?v=cxpgd_a4Btk this is an amusing video of a guy doing his bike. its got more modules and some post update set up sequences to complete - does it at home in 27 mins

    anyway got my R1200GS fossil updated took a whole 8 mins of programming and 13 mins of workshop time, engine remapped designed to fix 3 faults.

    rather frustratingly the idiots at BM didn't do it 8 years ago when I first asked, response then was we don't do that sort of thing sir... turns out the truth is YES they do and built a very good system to programme the whole bike in one hit.

    a vehicle integration update checks all modules, writes the software afresh to all modules, and if there's anything newer sitting on the server in Germany it updates them.
    with the right kit you can review the vehicles software history

    from the factory build May 2007 - K024-07-05-520 (so they already bug fixed 2 versions of that months "new software")
    last update when it was registered Jan 2008 - K024-08-01-500 ( I think this was when the where updating from a CD prob v10)
    current version done Feb 2018 (I-level) Jul 2017 - K024-17-07-500 (should have been done with K024-17-11-500 but would be nothing new anyway, just proves this dealer doesn't bother to keep his software up to date and probably explains the crashed software on 4 GS's with the new LCD display they failed to update correctly at Christmas )

    on my bike the alarm was updated, instrument cluster was up to date, abs not modified but subsequent checking the module is already on current software, chassis electronic (ZFE) up to date, engine remapped

    to fix
    engine stalling (with a car clutch I've never stalled a bike as often as this in 40 years of biking)
    poor idle (rough and lumpy)
    increased knock sensitivity (detonates heavily in summer under heavy use at 6500rpm & flats spots as anti knock cuts off ignition)

    it does seem to run much more smoothly and makes a fraction more go under 2k. Appears to have lost a bit of top end go, but need to redo my power commander to suit the new map, as maybe running to lean now. I know the previous UK importer of dynojet kit, he was saying most bikes run way too rich at the top end and the CAT sensor leans it off. I was running some 10% less after 60% throttle on PC with the old map, so I'll shove a bit more in an see where it ends up

    this leaves me pondering an update to the new toy.

    I had the BM alarm added and asked they update to latest I-level, they said they did, showed me a print out that they did it and as per most dealers are lying cheats as they definitely didn't update it !!!

    the nearly new ABS module is on the wrong software
    the engine is on it original crap map, when they did an update much like the guy above is trying to do to his bike
     
    Last edited: Apr 18, 2018

Share This Page