09 C220 CDI - Cold Starting Issue

D_smith_1188

Senior Member
Joined
Apr 16, 2016
Messages
46
Reaction score
1
Location
Grimsby, England
Your Mercedes
C220 2009 2.1
Hi,

Over the last week (mornings only) take two turns of the key to fire up, first time does turn over but wont start. figured it because we have had a cold snap, once its been started it does miss a beat. then for the rest of the days starts fine every time.

Strange one.
 

LostKiwi

Senior Member
Joined
Aug 25, 2006
Messages
26,455
Reaction score
15,903
Location
Midlands / Charente-Maritime
Your Mercedes
'93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
Poor starting on diesels is typically either related to air leaks or glowplugs.
 

sensor555

Senior Member
Joined
Feb 15, 2010
Messages
92
Reaction score
6
had similar problem on my E320CDI. glow lamp on dash went out after 4/5 seconds. still difficult to start and needed a jump star, then perfect rest of the day. Removed glow plugs and bench tested them with a battery, found although they were heating up they we not glowing red at the tip. Changed for new ones and solved problem.
 

Wighty

Senior Member
Joined
Aug 4, 2016
Messages
10,703
Reaction score
7,973
Location
Sunny Essex
Your Mercedes
W211/E320cdi/2009 and CLK200k 2009
Or Glow plug relay ? Best get any codes read before throwing any money at the wrong things
 

umblecumbuz

Senior Member
Joined
Sep 20, 2010
Messages
4,430
Reaction score
1,846
Location
Wales and Gozo
Your Mercedes
S204 and CLC 204 cdi, MX5, Kia Soul
On balance this does sound like a glow plug issue, but if this is the 646 motor, they will start even if all glowplugs are inop. unless they hit Arctic weather.
They're good that way.
So it needs sorting, but not an urgent problem.

If it was air in the fuel, this would show up at other times also, even with a warm engine.
 


Chris Knott Insurance, see oursticky posts here!
www.ckinsurance.co.uk
Top Bottom