107 Weird Electrical problem

KRANK

New Member
Joined
Apr 27, 2009
Messages
3
Reaction score
0
Location
Marylebone, London
Your Mercedes
250, 280CE, 280SE, 450SLC
Recently purchased a 1980 450 slc.
yesterday lost power to a number of systems.

Power windows not working and some instruments no longer working.
Odd thing is that some dials on the instruments panel are working while others have stopped.

Oil pressure gauge and speedometer work but no reading on temp gauge or rev counter(!)

Have checked fuses and they look OK.

The only change made to electrics is a recently installed replacement alternator which has a slightly higher rating than the original,
The company that supplied and fitted it (Sahib's auto electrics) said it would not affect any other systems.
I will be looking to find a mobile mechanic to sort it out but
any pointers toward a likely cause would be much appreciated.

Cheers
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
40
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
the oil gague and speedo are mechanical systems, and so are not related to your electrical gremlins. do the windows work with the door open by any chance? the alternator should be fine - assuming it`s not 24v or fitted by a butcher! check every thing electrical to be sure you have the complete list. also those torpedo fuses can look ok but have damaged ends from poor contact - the 107s have a tendancy to leak water into the fuse box from a rotten bulkhead.
 
OP
K

KRANK

New Member
Joined
Apr 27, 2009
Messages
3
Reaction score
0
Location
Marylebone, London
Your Mercedes
250, 280CE, 280SE, 450SLC
  • Thread Starter
  • Thread starter
  • #3
Hi Alex.
Many thanks for your input.
You obviously know your way around these cars.
Yes, the bulkhead is rotten.
Yes, there is water coming into the car around the footwells.
And the windows DO operate if the doors are opened (what is the cause of it?)

best,

KRANK
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
341
Age
87
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
These things a 2 separate things.

When the doors are ope it uses the comfort relay in the fuse box,,and you have a separate box for the in the car for closing,,I will post back on it,,It will be a water problem I think
 

Alex Crow

Senior Member
Joined
Jul 9, 2009
Messages
10,677
Reaction score
40
Location
Super Suffolk
Your Mercedes
W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
windows are live when the relay says so. relay is live when door pin switches say so, or ignition is on. instruments work when ignition is on. there is a link then, ignition output or possible power supply issue but go back to those fuses and remove one at a time and check the ends for signs of arcing/corrosion.
 


As a member of ourMercedes Owners' club, you will enjoy numerous savings on an expanding range of services including, Insurance, Parts and Servicing, RAC Membership plus much more.MBOmembers can save around £200.00 a year. You can join from as little as £30.00 and start to enjoy these savings immediately. You receive our monthly magazine and free classified ads when you decide to trade up a model.
Top Bottom