1993 w140 missfire

12.5EVO3

Senior Member
Joined
Dec 29, 2010
Messages
53
Reaction score
0
Location
Midlands
Starts fine then as it warms it starts to miss then clears and runs fine. Any ideas?
 
OP
1

12.5EVO3

Senior Member
Joined
Dec 29, 2010
Messages
53
Reaction score
0
Location
Midlands
  • Thread Starter
  • Thread starter
  • #3
That sounds a bit worrying. How can test the MAF

By the way its a 5.0l v8
 
Last edited:

Ben Longden

Senior Member
Joined
May 30, 2010
Messages
411
Reaction score
8
Location
Echuca, Victoria, Austrayamate
Website
www.benlongden.com
Your Mercedes
W203 220CDI. Silver with grey and black trim. 1992 W140 400SEL Silver. 1999 CLK430 (missus)
My 92 W140 had an intermittent rough firing issue for some time.
Thought it was the MAF, but alas not.... even after STAR tests and reports.

Chugged into an experienced auto elec, and he had the problem nailed before I finished driving into the shop.

It was a new set of spark leads that was needed.

HTH
Ben
 
OP
1

12.5EVO3

Senior Member
Joined
Dec 29, 2010
Messages
53
Reaction score
0
Location
Midlands
  • Thread Starter
  • Thread starter
  • #5
It does look like it has had a new set of leads, also the old ones are still in the boot.
 

robparker

Senior Member
Authorised Forum Supporter
Joined
Apr 18, 2006
Messages
2,695
Reaction score
426
Location
Taunton
Your Mercedes
220d (115), 190d (201), c63 (204), 220ce (124)
Done the caps in the last year or 2? If not do them again, with bosch ones, they are bad on these engines especially if not driven regularly up to temperature and fail often
 


As a member of ourMercedes Owners' club, you will enjoy numerous savings on an expanding range of services including, Insurance, Parts and Servicing, RAC Membership plus much more.MBOmembers can save around £200.00 a year. You can join from as little as £30.00 and start to enjoy these savings immediately. You receive our monthly magazine and free classified ads when you decide to trade up a model.
Top Bottom