2001 C240 - all electrics failing

michaelarran

Member
Joined
Mar 6, 2007
Messages
14
Reaction score
0
I had the front passenger size indicator bulb fail a couple of months ago, and although I changed the bulb to a working one, I still had the fault. Odd, but a service was coming up soon.

Today my wife started it and nothing happened - no engine, and no electrics. I just retrieved it, and it started first time, then the engine stopped, but the electrics were still on. After a few minutes the engine started (with the fan on constantly), and the electrics were on - and then the electrics failed again, although the engine and fan kept running. I limped it home, and the electrics recovered enough to let me lock it.

Any clues which fuses(s) may have failed, so I can get it into the garage safely?

Thanks
 

Cole@MBS

Forum Supporter
Authorised Forum Supporter
Joined
Dec 1, 2008
Messages
13,654
Reaction score
812
Age
51
Location
Hedge End, Southampton
Website
www.mbssouthampton.co.uk
Your Mercedes
124 300 CE 24 Coupe, C220CDI, 1959:Morris Minor
You need a short test done, that sounds like the engine ecu has lost comms on the CAN, hence default, the fan coming on!!
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
I take it the car is a 202 this is a change of car year.

If it is it will be water ingress in the fuse relay box.
 
OP
M

michaelarran

Member
Joined
Mar 6, 2007
Messages
14
Reaction score
0
  • Thread Starter
  • Thread starter
  • #4
Reg is nn51 nnn, so I think that means it is a 203. i.e the body type before the new ones introduced last year - I'm no expert, as you have probably realised.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Reg is nn51 nnn, so I think that means it is a 203. i.e the body type before the new ones introduced last year - I'm no expert, as you have probably realised.

OK for a 203 (the number is at the bottom of the windscreen passenger side) then please ignore what I said and go with SAM and have a read out, I too think on this it will be a SAM fault,,but not SAM's fault:D
 

Cole@MBS

Forum Supporter
Authorised Forum Supporter
Joined
Dec 1, 2008
Messages
13,654
Reaction score
812
Age
51
Location
Hedge End, Southampton
Website
www.mbssouthampton.co.uk
Your Mercedes
124 300 CE 24 Coupe, C220CDI, 1959:Morris Minor
OK for a 203 (the number is at the bottom of the windscreen passenger side) then please ignore what I said and go with SAM and have a read out, I too think on this it will be a SAM fault,,but not SAM's fault:D

Its always my fault Malc:(:(
 


www.W140.co.uk&www.r129.co
Specialist in parts for W140 and R129 Mercedes-Benz models.
Top Bottom