2010 W245 B Class non start

Nick Jones

New Member
Joined
Nov 17, 2020
Messages
3
Reaction score
0
Your Mercedes
W202
Hi there, wondered if anyone has any advice on this problem. The car has a recent new battery and was parked up on
driveway one night.
Went to it next morning to find it won't start. The ignition turns on as normal but go to start & nothing - doesn't even crank & won't come out of park. Also in instrument panel says 'brake fluid check level'
I have so far replaced the battery & brake pedal switch. I have also checked brake fluid level and level switch operation all ok. I have read codes with Star which brought up the following:
IMG_20201117_174025.jpg just wondered if anyone has known anything similar??:cool:
 
OP
N

Nick Jones

New Member
Joined
Nov 17, 2020
Messages
3
Reaction score
0
Your Mercedes
W202
  • Thread Starter
  • Thread starter
  • #2
Hi there, wondered if anyone has any advice on this problem. The car has a recent new battery and was parked up on
driveway one night.
Went to it next morning to find it won't start. The ignition turns on as normal but go to start & nothing - doesn't even crank & won't come out of park. Also in instrument panel says 'brake fluid check level'
I have so far replaced the battery & brake pedal switch. I have also checked brake fluid level and level switch operation all ok. I have read codes with Star which brought up the following:
index.php
just wondered if anyone has known anything similar??:cool:
 

Blobcat

Moderator
Joined
Feb 8, 2006
Messages
39,102
Reaction score
27,992
Location
Grange Moor
Your Mercedes
R171 SLK280, Smart R451, Land Rover 110 County SW, 997 C2S, R1250 GSA TE 40th, CBR600FP
Hello and welcome

I’ve merged your threads for you as there’s no need to post in multiple sections
 
OP
N

Nick Jones

New Member
Joined
Nov 17, 2020
Messages
3
Reaction score
0
Your Mercedes
W202
  • Thread Starter
  • Thread starter
  • #4
Much appreciated. Thankyou. :)
 

alexanderfoti

MBO Forum Supporter
Authorised Forum Supporter
Joined
Mar 25, 2010
Messages
15,163
Reaction score
6,342
Location
Tonbridge
Your Mercedes
W221 S65 AMG - W204 C63 AMG + Various other MB's
Looks like a can fault.

Either dodgy wiring, or water in a a can connector or the EIS(ignition switch)/central gateway (depending on year) is playing up.
 

Steve@Avantgarde

Forum Supporter
Authorised Forum Supporter
Joined
Dec 8, 2009
Messages
7,331
Reaction score
2,000
Location
Bristol/Somerset
Website
www.avantgarde-automotive.co.uk
Your Mercedes
E300 Coupe AMG Line PP/NE, SLR McLaren Roadster, SL55 & C32AMG
I would say thats a flat battery....the ignition will turn on later models even with a flat battery (models after 2009 I think).

If you have STAR which it looks like you do, go to EZS, actual values and see if Terminal 50 is being turned on, if the answer is no, I would check the battery, there isn't enough guts to fire up the CAN network. You could have a drain and all your faults are being caused by low voltage.
 

alexanderfoti

MBO Forum Supporter
Authorised Forum Supporter
Joined
Mar 25, 2010
Messages
15,163
Reaction score
6,342
Location
Tonbridge
Your Mercedes
W221 S65 AMG - W204 C63 AMG + Various other MB's
I would say thats a flat battery....the ignition will turn on later models even with a flat battery (models after 2009 I think).

If you have STAR which it looks like you do, go to EZS, actual values and see if Terminal 50 is being turned on, if the answer is no, I would check the battery, there isn't enough guts to fire up the CAN network. You could have a drain and all your faults are being caused by low voltage.

Good shout, don't forget the basics!
 

You lost your key ? Or maybe you need a spare! Your vehicle imobilliser does not respond anymore? WE CAN FIX THEM ALL !! Mobile ! Save Time and Increase Profits With us !
Top Bottom