99 slk 230 cutting out

nigel robinson

New Member
Joined
Sep 13, 2009
Messages
6
Reaction score
0
My 99 slk230 is cutting out it doesnt matter if the engine is hot or cold and when it cuts out the cooling fan comes on. I try to restart but the engine doesnt turn over. Eventually ot starts and runs perfect until the next time. I know other slk owners have had the same problem and it seems that it may be the crankshaft position sensor. Firstly where is it, what does it look like and is it easy to replace. Can anyone help.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
If the fan comes on and the engine does not turn over,,then not the CPS,,I will post back
 

Cole@MBS

Forum Supporter
Authorised Forum Supporter
Joined
Dec 1, 2008
Messages
13,654
Reaction score
812
Age
51
Location
Hedge End, Southampton
Website
www.mbssouthampton.co.uk
Your Mercedes
124 300 CE 24 Coupe, C220CDI, 1959:Morris Minor
If the cooling fans are running flat out, this means the car has lost comms with the engine ecu, putting the fan on to default!
 
OP
N

nigel robinson

New Member
Joined
Sep 13, 2009
Messages
6
Reaction score
0
  • Thread Starter
  • Thread starter
  • #4
i have also read that it culd be solder joints on the K40 module. Does that make any sense.
 

Cole@MBS

Forum Supporter
Authorised Forum Supporter
Joined
Dec 1, 2008
Messages
13,654
Reaction score
812
Age
51
Location
Hedge End, Southampton
Website
www.mbssouthampton.co.uk
Your Mercedes
124 300 CE 24 Coupe, C220CDI, 1959:Morris Minor
It do,

Next to the battery is a black box with strip fuses, cant for the life of me remember, but, i seem to have it in my head a problem i once found in there!

Just check there all clean and happy!
 
OP
N

nigel robinson

New Member
Joined
Sep 13, 2009
Messages
6
Reaction score
0
  • Thread Starter
  • Thread starter
  • #6
is that the one with the 40amp fuse and 5 15amp fuses on the top

Nige
 
OP
N

nigel robinson

New Member
Joined
Sep 13, 2009
Messages
6
Reaction score
0
  • Thread Starter
  • Thread starter
  • #8
ok will clean and replace with new fuses. Failing that can you think of anything else it could be.

Nige
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
I have seen this fault where the fan comes on and engine will not start,,but cant find it right now:confused::confused:
 
OP
N

nigel robinson

New Member
Joined
Sep 13, 2009
Messages
6
Reaction score
0
  • Thread Starter
  • Thread starter
  • #11
if i get the car onto a diagnostics device will this pin point the poblem.

Nige
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
I am still checking on this and I will post back, and yes diagnostic on STAR should say what has gone wrong
 


Chris Knott Insurance, see oursticky posts here!
www.ckinsurance.co.uk
Top Bottom