A class cdi 170 (168) question ?

krmoto

Member
Joined
Jan 1, 2009
Messages
22
Reaction score
0
Hi,
I am still trying to get my car going, can someone please tell me when the immobiliser is activated if all the dash lights will light up on the 2nd position of the ignition switch.
Also there is a kind of light clunking noise coming from under the passenger side wing near the bulkhead which seems to have something to do with the activation of the windows, what is this and what does it do because l think it may be the reason the car wont start.

On 1st position of ignition
drivers window working and the car will start.
drivers window NOT working and the car will not start.

When the car is not starting mode there is no cold start light on the dash and the rad cooling fan comes on and no cranking over.
Any thoughts would be very welcome.:confused:
 

BlackC55

Senior Member
Joined
Feb 23, 2007
Messages
2,488
Reaction score
0
Location
South coast
Your Mercedes
C43
You need it plugged into a Star really.

It sound like either a dodgy earth or a failed control unit.
 
OP
K

krmoto

Member
Joined
Jan 1, 2009
Messages
22
Reaction score
0
  • Thread Starter
  • Thread starter
  • #3
Many Thanks,
I have been round all the earths l can find, but the control unit sounds likely becos this car has had many intermitent strange problems with elec's in the past that have gone away after a bit of fiddling like leave it for a few days or disconnect the batt ect ect and then the problem will come back but now it does'nt want to clear itself whatever i do.
Is the control unit the clunking l can hear under the wing? also are they coded to the car?
cheers for now.
 

mattkh

Senior Member
Joined
Aug 2, 2006
Messages
2,589
Reaction score
227
Location
England
Your Mercedes
A160 W168 1999 1.6
Hi
Is the car stored in a very damp area
 
OP
K

krmoto

Member
Joined
Jan 1, 2009
Messages
22
Reaction score
0
  • Thread Starter
  • Thread starter
  • #5
yes l would say the uk is very damp this time of year;) other than that l would'nt say so, but why do you ask?
any thoughts would be good. are you thinking corrosion or circuit boards breaking down?
cheers.
 
Last edited:

mattkh

Senior Member
Joined
Aug 2, 2006
Messages
2,589
Reaction score
227
Location
England
Your Mercedes
A160 W168 1999 1.6
are you thinking corrosion or circuit boards breaking down?cheers.
Hi
I am thinking moisture in the electrical connectors to the automatic gearbox.
Also, is the battery fully chatged.
 
OP
K

krmoto

Member
Joined
Jan 1, 2009
Messages
22
Reaction score
0
  • Thread Starter
  • Thread starter
  • #7
Hi mattkh,
This A class is a semi auto and the clunking l can hear under the passenger inner wing is apparently the motor that drives the auto clutch and there is definatly something not right with it, and l have fully charged the battery several times.
 

Use the code MERCEDES and get 10% MBO Club Discount, oilman's website:www.opieoils.co.uk

register for news and offers email:sales@opieoils.co.ukphone: 01209 202944
Top Bottom