1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

A140 AIRBAG LIGHT DRIVIND ME MEAD!!

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by a140ann, Jan 4, 2013.

  1. a140ann

    a140ann Active Member

    Messages:
    30
    Likes Received:
    0
    Joined:
    Feb 13, 2011
    Location:
    leamington
    Your Mercedes:
    a140 2001
    you can see how mad by the misspelt title - opps!!

    The airbag light is illuminated on my 2001 a140, it goes off if i have a passenger over a certain weight - same issue as others.

    I purchased the bypass unit off ebay - http://www.ebay.co.uk/itm/271111465512?ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1439.l2649 and it looks like ist worked for everyone else - its not working for me!

    now i still have the airbag light but also the airbag off light is also on near the the handbrake.

    The MOT is next month so it needs to be off - help!!!

    shall i just get a new sensor mat or is there another solution??

    Really fed up with it now

    thanks
     
    Last edited: Jan 4, 2013
  2. OP
    a140ann

    a140ann Active Member

    Messages:
    30
    Likes Received:
    0
    Joined:
    Feb 13, 2011
    Location:
    leamington
    Your Mercedes:
    a140 2001
    someone must have an idea?? Its suppose to be a common thing...heelllppppppppp :-(

    thank you x
     
  3. cleverdicky

    cleverdicky Senior Member

    Messages:
    2,385
    Likes Received:
    2
    Joined:
    Feb 25, 2009
    Your Mercedes:
    MB
    Give the seatbelt retainer a wiggle. i.e push the clip in and out a few times.

    I always took my washing down to mums to use her washing line (since they are mostly banned in modern developments. ahem)
    Anyway, the weight used to trigger the beeping, so next time at a breakers I obtained a spare seatbelt clip. And it thinks a person is there. - no beeps.

    If i leave the clip in, with nothing on the passenger seat, ie no weighty laundry bag, then my yellow airbag OFF light lights :)
    So try the connecting the passenger seatbelt clip a few times, maybe the switch is just sticking ;)
     
  4. dog68

    dog68 Senior Member

    Messages:
    52
    Likes Received:
    0
    Joined:
    Sep 27, 2010
    Location:
    cambridgeshire
    Your Mercedes:
    V class 2.3 petrol/lpg
    Have a look under the seat, you should see a connection that goes to the seat mat sensor, inspect the connector, and wiring, something may have caught it.
     
  5. OP
    a140ann

    a140ann Active Member

    Messages:
    30
    Likes Received:
    0
    Joined:
    Feb 13, 2011
    Location:
    leamington
    Your Mercedes:
    a140 2001
    ill try the retainer tomorrow.

    did the connector under the seat - no good - had the whole seat out before trying this bypass thing.

    Blooming this is an MOT failure now grrrrrr

    thank you x
     
  6. OP
    a140ann

    a140ann Active Member

    Messages:
    30
    Likes Received:
    0
    Joined:
    Feb 13, 2011
    Location:
    leamington
    Your Mercedes:
    a140 2001
    should say, took the bypass back off and back to "normal" now. srs light on but everything else off. x
     
  7. cleverdicky

    cleverdicky Senior Member

    Messages:
    2,385
    Likes Received:
    2
    Joined:
    Feb 25, 2009
    Your Mercedes:
    MB
    You dont want to go touch yellow seat / airbag connectors with key in.
    Any connection fault with key in will trigger the SRS fault and now only plugging into a star or good pc diagnostic will clear it.
     
  8. OP
    a140ann

    a140ann Active Member

    Messages:
    30
    Likes Received:
    0
    Joined:
    Feb 13, 2011
    Location:
    leamington
    Your Mercedes:
    a140 2001
    Popping to the garage tomorrow to see if they can clear it, someone told hubby to try starting it with the connectors not connected to see which lights were on and off then :-S

    i will beat this light lol x
     
  9. scotty2hotty81

    scotty2hotty81 Senior Member

    Messages:
    132
    Likes Received:
    1
    Joined:
    Nov 1, 2006
    Airbag light is not a mot failure.
     
  10. callebergman

    callebergman Guest

    Hi An!

    I have the exact same problem, also used the bypass unit :(( Did you manage to fix it? In that case how?

    Many thanks from a frustrating Swede!
    Micael
     
  11. MB TECH WARRINGTON

    MB TECH WARRINGTON Senior Member

    Messages:
    572
    Likes Received:
    0
    Joined:
    Jun 2, 2008
    Have you guys tried erasing the fault codes after fitting the bypass unit.

    Also have you re-read the codes after installing the unit?
     
  12. mattkh

    mattkh Senior Member

    Messages:
    1,588
    Likes Received:
    41
    Joined:
    Aug 2, 2006
    Location:
    England
    Your Mercedes:
    W168 1999 1.6
    Hi
    I think this may be a 'passenger-sitting' sensor problem.
     
  13. Howard

    Howard Senior Member

    Messages:
    815
    Likes Received:
    0
    Joined:
    Feb 9, 2010
    Your Mercedes:
    CLS 500 / A 190
    SRS system light is
     
  14. mattkh

    mattkh Senior Member

    Messages:
    1,588
    Likes Received:
    41
    Joined:
    Aug 2, 2006
    Location:
    England
    Your Mercedes:
    W168 1999 1.6
    Hi
    When you disconnect the electrical red connector, do hear a continuous beep ?
     

Share This Page