A209 CLK Front Parking Sensors (A004 542 87 18) Whinging

crippo2

Senior Member
Joined
Mar 9, 2014
Messages
292
Reaction score
75
Location
North Oxfordshire
Your Mercedes
SL350 (R230) & CLK350 (W209)
Parktronic is moaning that one or more of the front parking sensors is on the fritz. The other sensors, their noises and displays all seem OK. Sensors are clean
Yet to put it on STAR.
In the meantime has anyone experience of:
1) if the front left hand portion of the dash display sector is showing all yellows and reds, If the failure is not a bumper mounted sensor, could it be dirty connections? Does no or degraded connection to a sensor fool the system into believing that these is a very close obstruction?
2) If the failure is possibly something else (but seemingly limited to just the front nearside quarter) what does experience say it might be?
3) as replacements has anyone tried lookalikes from eg China - See https://tinyurl.com/y9u3kv7j. Any good, both for sensitivity and longevity?

Anything else I am missing?
All help gratefully received
 
OP
C

crippo2

Senior Member
Joined
Mar 9, 2014
Messages
292
Reaction score
75
Location
North Oxfordshire
Your Mercedes
SL350 (R230) & CLK350 (W209)
  • Thread Starter
  • Thread starter
  • #2
Update
STAR tells me no recorded faults, but also says one front sensor persistently believes it is close to an object, thus showing lights and sirens on the display.
So new sensor ordered, then bumper off & new sensor fitted - glad the weather is getting warmer!
 


A truly one stop site for Mercedes owners. Very experienced – friendly – down to earth – cost effective repairs offering either genuine or same quality parts so that you do not compromise your Mercedes heritage or reliability. Tel: 01406 422457fleetroadgarage.co.uk
Top Bottom