Airmatic visit workshop,

colechelle

Resigned
Joined
Jun 30, 2005
Messages
1,350
Reaction score
0
Age
51
This will be a up and common fault seen by all R, ML, CLS,Gl and E class models!

Driving along and the first thing thing you will notice is airmatic, visit workshop on the dash, no panic, i run my work R,class (fully loaded with tools etc) for another 2 days,

Right what happens is the valve block stars to leak and and then the compressor is asked to work for a lot longer than built for, or the other reason is the relay sticks and burns the pump out, for what ever reason you need to change pump, relay and valve body.

jack up o,s, (n,s on E & CLS) remove front undertray, there you will find pump, undo the 3 10mm nuts holding the pump up up, watch for the springs and washers as you lower the pump, one main plug for the live and earth and one other plug for the relief valve, one 10 mm nut which is the supply line to the valve body, that removes the pump, valve body is just behind the pump, 7 airlines but all colour coded, so you have no excuse to refit them wrong, relay is now modified, on the R and ML it is the third one in from the wing in the front fuse box(green in colour) rear of the front SAM on E & CLS,

Refit in oppersite, MB state you need to teach the pump in, nonsense! you dont, it will store a fault but wont be currant so all warnings signs will be out!

any probs on doing this please feel free to pm me

Cole
 

rafstar85

New Member
Joined
Dec 13, 2009
Messages
3
Reaction score
0
Location
Witney, U.K
Your Mercedes
S350
To Cole.
Thanks for your insight in the airmatic suspension problem. Any chance you do sort mine out?

Rafi
 

ashy2k2

New Member
Joined
Dec 28, 2009
Messages
2
Reaction score
0
Air suspension problem

Hi,

I have a merc s320 CDI 2001. I was driving on when I suddenly had to break hard when somebody pulled out in front of me. When I got home the O/S front seemed to be higher than the rest of the car and there was a loud clunking sound constantly. The vehicle O/S front stayed up and this lasted for at least 10 mins and even when the keys were out of the ignition. The noise went and the car went to the normal position when parked on the drive.

The next day the car was extremely low and the manual button to raise the suspension didn’t make a difference. Based on this I guessed the worse and assumed the pump had gone. After getting quotes from local Merc Specialists I was quoted over £1000+.

After looking at the very helpful reviews I decided to strip the os front to take out the pump. When testing it with a tested the main thick wires (positive/negative) there was no power. When checking the main 40 amp fuse I noticed it had blown. I changed this and also the relay. (1st relay was faulty so had to purchase second) After all this there is power there but when I plug the pump back in nothing happens. No sound or anything. I have tried plugging the pump directly to a battery and sometimes works and sometimes does not. When touching it to a battery when working if I break the connection then make the connection again it doesn’t work. Is this my compressor/motor?

A bit of a long winded one but any help????
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Hello and welcome, SAM is the man on these and I hope that he will see your post tonight
 

stumpy

Senior Member
Joined
Jul 29, 2006
Messages
1,611
Reaction score
2
Your Mercedes
various
SAM, should the pump be really noisy on a Viano? I.E. you can hear it over everything else for about 10 secs when there is a change in load ??
 

Cole@MBS

Forum Supporter
Authorised Forum Supporter
Joined
Dec 1, 2008
Messages
13,628
Reaction score
765
Age
51
Location
Hedge End, Southampton
Website
www.mbssouthampton.co.uk
Your Mercedes
124 300 CE 24 Coupe, C220CDI, 1959:Morris Minor
SAM, should the pump be really noisy on a Viano? I.E. you can hear it over everything else for about 10 secs when there is a change in load ??


Err, no, they are not the quitest of pump, but not that bad!!!
 

desperate

Member
Joined
Sep 4, 2006
Messages
17
Reaction score
0
Desperate

Colechelle,
On the 17/06/08 you posted an illuminating comment on `airmatic-visit workshop`, does this apply to the S class 320 TD? If so, to your knowledge, is the procedure the same - and will I do any damage by driving until it can be fixed? Sounds expensive to me and I`ve just bought it..! Would appreciate yours or any other members input please,

Desperate.

NB. Would a STAR diagnostic identify the precise problem?
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Colechelle,
On the 17/06/08 you posted an illuminating comment on `airmatic-visit workshop`, does this apply to the S class 320 TD? If so, to your knowledge, is the procedure the same - and will I do any damage by driving until it can be fixed? Sounds expensive to me and I`ve just bought it..! Would appreciate yours or any other members input please,

Desperate.

NB. Would a STAR diagnostic identify the precise problem?

Colechelle is now SAM UNIT start a new post if he does not see it, STAR will find most faults what year is the car
 

Xtractorfan

Senior Member
Joined
Nov 16, 2007
Messages
6,084
Reaction score
156
Your Mercedes
S class
If the car is still driveable then it will be ok to drive it...Some people fit bigger wheels and tyres and these can cause problems when the suspension doesnt rise..
Best to have an indie check your suspension and diagnose the problem..most likely needs a new compressor and relay..it comes as a kit..around £300
 

desperate

Member
Joined
Sep 4, 2006
Messages
17
Reaction score
0
Desperate

Thanks Malcolm,

It`s a 2001 model with 80k on the clock. Just bought it, didn`t show up on a 12 mile test drive including M/way. You mentioned tyre/wheel changes, this has brand new tyres - 225 x 60 x 16. Would this be the correct size? Perhaps this is the problem, - clutching at straws now...! Otherwise, a lovely motor,

Desperate.
 

desperate

Member
Joined
Sep 4, 2006
Messages
17
Reaction score
0
Xtractorfan,
thanx for your input, all really appreciated, know zilch about motors but hooked on Mercs...!
Desperate.
 

Ram05

Member
Joined
May 13, 2009
Messages
24
Reaction score
0
Your Mercedes
W220 - S320
Xtractorfan,
thanx for your input, all really appreciated, know zilch about motors but hooked on Mercs...!
Desperate.

Hope you have sorted out issue now, can you let us know the cause and its resolution.

BR
 


Prestige Motor Group is Hertfordshire's Premier INDEPENDENT MERCEDES BENZ SPECIALIST. We offer a service exceeding Main dealership expectations and HUGE savings on Main Dealership Prices. WE BEAT ANY GENUINE QUOTE! Prestige Motor Group pride ourselves on delivering excellent customer service as we believe the customer and the Car deserve the best.
Tel: 01462 672458www.prestigemotorsofhertfordshire.co.uk/
Top Bottom