1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Alternator issue??

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by StuggyZX10, Dec 9, 2012.

  1. StuggyZX10

    StuggyZX10 Active Member

    Messages:
    44
    Likes Received:
    0
    Joined:
    Jul 14, 2007
    W211 Alternator issue??

    Good evening in need of some advice/information
    I am having some issues with my 2003 W211 E320 Diesel Avantagarde saloon.....i thought i had a duff rear battery as i was getting the conveniance functions disabled warning and also the Red Battery/Workshop warning sign showing. I renewed the rear battery and checked the front battery and as this was over 5yrs old i replaced this as well. All was well for a couple of days then the warning's returned...i dont know why i did not check the voltage output across the terminals of the rear battery at the start...but i have now checked this and its reading 11.5 way low and even with engine running no change so i guess its the alternator/regulator thats went...i will change this myself as i have access to a ramp/tools etc but would anybody know before i order a replacement alternator which one is fitted to my car/standard or water cooled from the car's VIN number and can the regulator be changed itself as this would save a few ££.........my car was registered in july 2003 and the VIN is WDB2110262A348224
    I will be calling my local merc dealer as i believe there was some electrical recalls issues with alternators and auxillary regulator's on these model's so hopefully they can check on the VMI if these have been done....

    sorry for the long winded query but any info would be appreciated ..thanks
     
    Last edited: Dec 9, 2012
  2. OP
    StuggyZX10

    StuggyZX10 Active Member

    Messages:
    44
    Likes Received:
    0
    Joined:
    Jul 14, 2007
    Sorted thanks for the help............:rolleyes:
     
  3. SL55 Mark

    SL55 Mark Senior Member

    Messages:
    2,648
    Likes Received:
    354
    Joined:
    Oct 1, 2012
    Location:
    South
    Your Mercedes:
    2004 SL55 AMG
    To be honest, sounded like you knew what you were doing, and were taking all the right steps. Glad you got it sorted.
     
  4. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    310
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    It is hard sometimes, I have been off air due to computer problems
     
  5. OP
    StuggyZX10

    StuggyZX10 Active Member

    Messages:
    44
    Likes Received:
    0
    Joined:
    Jul 14, 2007
    The wife doesn't seem to think so half the time lol...but yep it was the alternator and was bosch one..so all happy with no warning's showing :)
     
    Last edited: Dec 16, 2012

Share This Page