Audio 10 LCD back light?

INKJET

Active Member
Joined
Feb 26, 2006
Messages
27
Reaction score
0
One for Television??

The back light on my Audio 10 radio/cd player does not come on with the lights any more? the radio works fine and all other dash board light is ok including the climate control LCD stack above it.

I have manage to remove the radio unit from the rack (the Halfords guy had a merc release key) but the in puts are one for the aerial and a multi wire plug unit with about 15-20 wires?

Any idea's this site has yet to fail me

Inkjet
 
Last edited:

rpe2

Senior Member
Joined
Sep 25, 2006
Messages
2,863
Reaction score
2
Age
44
Location
Silchester
Your Mercedes
His: 2018 E220 d; Hers: 2016 SMAX
What car is it?
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
You should just be able to replace the bulb within the Audio 10,,take the cove off
 
OP
I

INKJET

Active Member
Joined
Feb 26, 2006
Messages
27
Reaction score
0
  • Thread Starter
  • Thread starter
  • #4
Clk 320 2000 model year
 
OP
I

INKJET

Active Member
Joined
Feb 26, 2006
Messages
27
Reaction score
0
  • Thread Starter
  • Thread starter
  • #5
got the radio out and top cover off, can't see any bulbs

The lower socket on the rear appears to have two LED in plug with receptors on the radio unit
 

rpe2

Senior Member
Joined
Sep 25, 2006
Messages
2,863
Reaction score
2
Age
44
Location
Silchester
Your Mercedes
His: 2018 E220 d; Hers: 2016 SMAX
Socket for the CD Changer
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
No, the rear one is a fiber optic and not that,,its possible that the display window or driver has failed if no back light
 
OP
I

INKJET

Active Member
Joined
Feb 26, 2006
Messages
27
Reaction score
0
  • Thread Starter
  • Thread starter
  • #8
richard

any idea about the location of the bulb?
 
OP
I

INKJET

Active Member
Joined
Feb 26, 2006
Messages
27
Reaction score
0
  • Thread Starter
  • Thread starter
  • #9
the display works fine, not a problem until it gets dark!!
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
any idea about the location of the bulb?

That last one that I fixed did not have that problem,,I will try and find out something more
 

rpe2

Senior Member
Joined
Sep 25, 2006
Messages
2,863
Reaction score
2
Age
44
Location
Silchester
Your Mercedes
His: 2018 E220 d; Hers: 2016 SMAX
No, the rear one is a fiber optic and not that,,its possible that the display window or driver has failed if no back light

Sorry, misread INKJET's post
 
OP
I

INKJET

Active Member
Joined
Feb 26, 2006
Messages
27
Reaction score
0
  • Thread Starter
  • Thread starter
  • #12
I can't remember if it light up with lights on or any time the radio is on, the latter i would guess?

Inkjet
 
OP
I

INKJET

Active Member
Joined
Feb 26, 2006
Messages
27
Reaction score
0
  • Thread Starter
  • Thread starter
  • #13
well guys i have put the radio back together and guess what ! it works fine now????

Ok so Radio 1 still sounds crap, but that must be me getting old!!

Once again thanks for your help
 


The SL SHOP YOUR ONE STOP SHOP FOR ALL THINGS SL, SERVICE & RESTORE, SALES, HIRE & PARTS
Choose from a wide range of superbly prepared SL’s each with a 12 month guarantee. We can service, update, re-trim, restore and repaint your 107 SL.
Choose from a 6 or 8 cylinder car for the day, the weekend, a month or a year. Contact us for a wide range of parts. Tel: 0844 414 2116 or visit our website atwww.theSLshop.com
Top Bottom