BAS / ESP /ABS after MOT work on 210

tjamesbo

Senior Member
Joined
Dec 26, 2006
Messages
1,438
Reaction score
86
Location
Sutton Coldfield, West Midlands
Your Mercedes
1999 CLK430, 2007 VITO 3.0V6 , W124's (1994 320TE , 1993 220TE ) , 07 2.5 X-Type
Dropped off the 320CDI for its MOT today mid morning the phone call comes New Track Rod End required and rear brake efficiency not up to spec and out between wheels £300 all told Including the MOT , as I am busy with Boat Problems at the moment I agree instead of doing it myself . On collecting the Car I get 40-50yds down the road and get the Beep warning followed by ABS BAS ESP and visit workshop so back to the Indie who resets it on the autologic Fault reader, drive down road and same again , another reset and we try again same warnings So its at theirs for a look tomorrow morning .
I am hoping its a simple fix and it wont cost me anything as it was all OK before the work last code fault read seemed to be steering angle sensor
I await slightly nervously
 
R

Ringway

Guest
Dropped off the 320CDI for its MOT today mid morning the phone call comes New Track Rod End required and rear brake efficiency not up to spec and out between wheels £300 all told Including the MOT , as I am busy with Boat Problems at the moment I agree instead of doing it myself . On collecting the Car I get 40-50yds down the road and get the Beep warning followed by ABS BAS ESP and visit workshop so back to the Indie who resets it on the autologic Fault reader, drive down road and same again , another reset and we try again same warnings So its at theirs for a look tomorrow morning .
I am hoping its a simple fix and it wont cost me anything as it was all OK before the work last code fault read seemed to be steering angle sensor
I await slightly nervously


Try turning the steering wheel lock-to-lock to clear the faults.
 
OP
T

tjamesbo

Senior Member
Joined
Dec 26, 2006
Messages
1,438
Reaction score
86
Location
Sutton Coldfield, West Midlands
Your Mercedes
1999 CLK430, 2007 VITO 3.0V6 , W124's (1994 320TE , 1993 220TE ) , 07 2.5 X-Type
  • Thread Starter
  • Thread starter
  • #3
They tried that also each time
Wonder if that last steering angle fault code is the key then ?
The wheel to wheel isnt resetting it
Its something they have done ... Likely as said all OK before the work
 
OP
T

tjamesbo

Senior Member
Joined
Dec 26, 2006
Messages
1,438
Reaction score
86
Location
Sutton Coldfield, West Midlands
Your Mercedes
1999 CLK430, 2007 VITO 3.0V6 , W124's (1994 320TE , 1993 220TE ) , 07 2.5 X-Type
  • Thread Starter
  • Thread starter
  • #4
Latest is its off for a 4 wheel alignment Its now 4:45 Sat and I havent heard its ready yet :(
 
OP
T

tjamesbo

Senior Member
Joined
Dec 26, 2006
Messages
1,438
Reaction score
86
Location
Sutton Coldfield, West Midlands
Your Mercedes
1999 CLK430, 2007 VITO 3.0V6 , W124's (1994 320TE , 1993 220TE ) , 07 2.5 X-Type
  • Thread Starter
  • Thread starter
  • #5
Its on its way back to me :D seems they had to centralise the steering wheel and readjust the tracking with ESP obviously you cant have anything in the system out of line.
 


Mercedes-Benz Servicing, repairs, engine and diagnostics
Wayne Gates - Mercedes-Benz, Unit F3, Phoenix Industrial Estate, Rosslyn Crescent, Harrow, Middlesex, HA1 2SP
Tel: 020 8863 9233
Established for 20 years all vehicles washed and vacuumed.
Top Bottom