Big Big Thank you - Re E240 MAF Problem

pilotbilly

Member
Joined
Feb 15, 2009
Messages
10
Reaction score
0
Location
Hampshire
Your Mercedes
E240
Hi there,

I'm a Newbie to MB and to the forum and just wanted to say a big thank you to those that are more knowledgable than the rest of us for helping on the Forum.

I bought my first ever MB a few months ago, a very tidy E240 Elegance with 76k on the clock and a full MB history. Being new to MB and automatic trans I accepted its poor acceleration, bizare choice of gear changes and the way it just revved itself silly without doing anything if you depressed the accelerator beyond 3/4 travel.

Only after some trawling thru this Forum did I come across talk of a faulty MAF sensor possibly being the cause of such problems.

Yesterday I replaced the MAF sensor and what a difference. Now I know what its like to drive an MB. I've rediscovered a love of driving that I lost years ago. Its now incredably light on its feet, probably gained 70+BHP and even whilst accelerating hard the gear changes are only noticable by the change in engine tone.

So special thanks to 'Television' and others posting on this topic. My 1200pound Ebay W210 is now a dream.

:D
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Hello and welcome,,I did an identical post today on a CLK.
Its always hard to go and tell some one to go and buy a MAF as it may not be the fault, when one reads of odd gearbox behavior, it does more or less confirm things.

The chances are that the last owner only sold the car because of that fault, they are very nice to drive, and thank you for joining and posting:D
 
OP
P

pilotbilly

Member
Joined
Feb 15, 2009
Messages
10
Reaction score
0
Location
Hampshire
Your Mercedes
E240
  • Thread Starter
  • Thread starter
  • #3
I thought the same. Having now experienced it working properly, the car would seem like its on its last legs with the faulty MAF sensor. :lol:

Thanks again. Was going to throw the keys at an MB agent to see if they could get it running better...... That would have been painful!
 
Top Bottom