C class 180 2009 parking light Fault,

Smudger201

New Member
Joined
Apr 4, 2020
Messages
3
Reaction score
0
Your Mercedes
C class 180 2009 597cc kompressor
Hello, I am having to replace the parking light bulbs on my Mercedes C180 Kompressor.
I’m using genuine Osram bulbs however about once sometimes twice a month they seem to blow.
Does anyone else have this issue? Or advice/information on this?
Thanks in advance
 

LostKiwi

Senior Member
Joined
Aug 25, 2006
Messages
31,363
Reaction score
21,629
Location
Midlands / Charente-Maritime
Your Mercedes
'93 500SL-32, '01 W210 Estate E240 (RIP), 02 R230 SL500, 04 Smart Roadster Coupe, 11 R350CDi
Almost certainly down to a poor connection somewhere. Check the bulb contacts and the connection of the loom to the light unit. Also check the earth for the light unit.
 
OP
S

Smudger201

New Member
Joined
Apr 4, 2020
Messages
3
Reaction score
0
Your Mercedes
C class 180 2009 597cc kompressor
  • Thread Starter
  • Thread starter
  • #3
Almost certainly down to a poor connection somewhere. Check the bulb contacts and the connection of the loom to the light unit. Also check the earth for the light unit.
Thanks for your advice I’ll look into what you have said.
 
OP
S

Smudger201

New Member
Joined
Apr 4, 2020
Messages
3
Reaction score
0
Your Mercedes
C class 180 2009 597cc kompressor
  • Thread Starter
  • Thread starter
  • #4
6B982A07-80A1-4A03-8011-18797C126FEC.jpeg Once I’d removed the headlamp yesterday afternoon I found that the bulb holder had melted itself to the headlamp!! New headlamp. So I’m thinking that your comment re a bad earth could be the problem
 


www.W140.co.uk&www.r129.co
Specialist in parts for W140 and R129 Mercedes-Benz models.
Top Bottom