c180 cold running probs

B

bob t

Guest
My 97 C180 wont idle untill warm and holds back till warm, throttle body clean , sounds like it has an air leak, pops back on starting, nothing comes up on codes, 100k miles, suspect hot film sensor/air mass sensor,looks clean,thermostat sensor checked ok ,any thoughts?? Only thing not serviced charcoal filter under rear wing
 
Last edited by a moderator:

turbopete

Senior Member
Joined
Feb 4, 2009
Messages
14,204
Reaction score
328
Age
46
Location
Spennymoor
Your Mercedes
2010 '60' Ford Mondeo 2.0TDCi Zetec (sorry)
there are usually a number of temp sensors. 1 for the electric fan, 1 for the guage on the dash and this may be the same 1 but may also have a seperate sensor for the temp to give readings to the ecu. if this has gone down, it may be telling the ecu that the engine is warm all the time and so the engine will be running too lean when cold (a bit like the old days of running cold and pushing the choke in too soon. the symptoms are the same!)
 
OP
B

bob t

Guest
  • Thread Starter
  • Thread starter
  • #3
Hi Turbopete, that was my thoughts too, had garage do a cold test to check the sensor, can only find the one at the front, think it does gauge and ecu, readings were ok on computer.
 

turbopete

Senior Member
Joined
Feb 4, 2009
Messages
14,204
Reaction score
328
Age
46
Location
Spennymoor
Your Mercedes
2010 '60' Ford Mondeo 2.0TDCi Zetec (sorry)
there will be 1 in the radiator for the fan and 1 in the cylinder head that does the guage and possibly the ecu too. the sensors have been known to fail but the guage etc still reads ok. it will be a 2 pin sensor on your car. 1 will probably be a variable earth for the guage and the other will be the same. i forget which way around it is but the resistance between the pin and earth in each case should either increase or decrease as the temp rises (decrease i think) and go the opposite way as the engine cools
 
OP
B

bob t

Guest
  • Thread Starter
  • Thread starter
  • #5
Thanks pete, I'll measure the resistance hot and cold and report back!! if i disconect the maf(hot film) when cold and start it will i cause any damage and will it tell me anything usefull?the garage computer showed the temp sensor to give correct cold readings.
 
Last edited by a moderator:
OP
B

bob t

Guest
  • Thread Starter
  • Thread starter
  • #6
PRoblem sorted, new MAF , not Bosch, too dear 200 quoted, Pierberg £90, goes like a rocket, gear changes vastly improved also, thanks.
 

AIB understand your special Mercedes deserves a special insurance policy. We have a refreshing attitude to insuring high performance, modified, imported or classic and vintage cars and deal with the UK’s leading insurers. We offer discounts for length of ownership, where the vehicle is kept overnight and limiting the mileage and can also cater for those clients who need higher mileage and business use. To obtain a quotation please call the team on 02380 268351 or visit us atAIB Insurance
Top Bottom