c180 Coupe - Wipers?

taffrhys

Member
Joined
May 29, 2007
Messages
10
Reaction score
0
Hi Guys,

I have a 2003 c180 Coupe, with a small wiper blade problem.

Got in the car one morning, to find they don’t work when you twist the stalk – on any setting. They do however work when you press the button at the end of the stalk, both to wipe the screen and spray the screen wash. All the other functions work find from the stalk – only the twist know for the wipers doesn’t.

I wanted to ask if this could be a relay problem? I thought that perhaps the timer relay might have failed?

It’s worth knowing that I left the stalk on and every now and again, the wipers do come on, but then stop again.

Any help would be great!

Rhys.
 

Dec

Senior Member
Joined
Nov 30, 2005
Messages
3,300
Reaction score
3
Location
Ireland.
Your Mercedes
W202
Sounds like a relay problem all right or possibly a problem at the twist switch, cleaning/inspecting the switch on a W202 can be useful, don’t know your car but it will likely be similar.
(W202= C class up to about 2000) (W203= C class after about 2000)

I don’t know where the relay/s are on your car but you could put your VIN number in here… http://www.detali.ru/cat/oem_mb.asp … and follow the links.

Dec
 


Specialist Classic Parts suppliers
SLS Im- & Export Handelsges.mbH, Industriestrasse 2 - 4, D-22885 Barsbuttel (bei Hamburg)
Tel. +49 (0)40 656 939-0, Fax +49 (0)40 656 939-399
Visit our website atwww.sls-hh-shop.deto view our comprehensive catalogue of parts for:
190SL (R121), 230 - 280SL (R113), 280 - 500SL/C (R/C107)
Good English spoken and friendly service to discuss your requirements.
Top Bottom