c200 cdi intermittent no start

2upfront

New Member
Joined
Jul 21, 2009
Messages
3
Reaction score
0
Hi
I have a c200 cdi automatic on a 04 reg.
The problem is occasionaly it just wont start, all instrument panel light etc work fine,but the engine wont turn over nothing. I can tell when this is going to happen as the drive program display on the instrument panel doesnt display the drive prog letters ie a C and a P. It just shows the 2 little boxes the letters should appear in. Also the shift stick is stuck in park. If i keep flicking the key back to off and then back to the last position before it should fire the engine eventually the letters appear and it will then start.
Had it in the garage, mech said it could be either faulty instrument panel or ignition switch, the macine showed faults but it was difficult to trace the problem.
A couple of other faults have happened occasionally - ABS light just comes on while driving, I stop turn engine off try to start again....nothing same problem as above.
Also i was checking fuses yesterday and after whilst trying to start and switching key back and forth the SRS light came on and wont go off. Even machine couldnt reset it.
Could anyone help me out please? i dont want to start paying for things that the mechanic isnt sure of which to replace.
Thanks guys
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
This is a hard one,,but welcome to the forum.

This could also be the shift selector, the ETC with part number 030 545 23 32 can send odd faults to the CAN bus on first turning the KEY all something like what you are getting.

Only by plugging into STAR will you get the right answer
 
OP
2

2upfront

New Member
Joined
Jul 21, 2009
Messages
3
Reaction score
0
  • Thread Starter
  • Thread starter
  • #3
thanks for the welcome. Was the machine the mech put it on not this STAR? it was a macine he could use for other makes of cars bmw etc. All on a box about as big as a laptop but thicker. Could this part you mention also cause the permanent srs fault light? just cant understand why sometimes it starts ok and then not. Also is there anyway of clearing the srs fault light as is machine wouldnt do it, i might just trade it in rather than stat spending a fortune
 

Cole@MBS

Forum Supporter
Authorised Forum Supporter
Joined
Dec 1, 2008
Messages
13,654
Reaction score
812
Age
51
Location
Hedge End, Southampton
Website
www.mbssouthampton.co.uk
Your Mercedes
124 300 CE 24 Coupe, C220CDI, 1959:Morris Minor
As Malc, ESM is going down, its a common fault with the 203,s! the machine you are talking about is not a star machine!!
 
OP
2

2upfront

New Member
Joined
Jul 21, 2009
Messages
3
Reaction score
0
  • Thread Starter
  • Thread starter
  • #5
sorry not very good wi th abbreviations, i think you mean engine starter motor and is this the part malcom mentioned? Any way to test it. sam unit i alo saw your thread about the fuse 54. mine is still the factory fitted 15amp not the 20 amp, but it hasnt blown.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
On these cars, the starters are driven by other other modules, they are also interlocked with things like the ETC and this has a starter lock out on it.

The car does need to go on STAR the special MB test set where all of the faults will be recorded
 
Top Bottom