C220 Coupe does not work properly after reaching 80 degrees

victor_X

New Member
Joined
Jun 18, 2009
Messages
4
Reaction score
0
Hi everyone!
I am the proud owner of a C220 SportCoupe from 2003 with 155 000 km, automatic tiptronic gearbox and I have it for 10 months. Recently started to make me some troubles, two exactly. I searched the forums but i didn`t found anyone with the same problems.

1. After going a few km`s and the engine reaches 80 degrees it does not accelerate and if i swtch it to manual does not overcome 3,000 laps . Usually if I drive a few km`s more it`s starting to function normal. I tested it with acceleration from 0 to 100 km and i got 10.3 sec like the manual says.

2. If i stop the car when the engine has around 80 degrees or more it does not start and it spins like it has no gas in the tank. The engine starts again after 30-40 minutes when the temperature is around 60 degrees or less and then it s working fine until it reaches 80 degrees again. I mention that the car never stopped by her self.

I went to the tester, a Launch X431 and I found 4 errors:

1. P1664 (-008) Electric heater open - Current and stored
2. P1354 (-002) Syncronization between cranckshaft and camshaft. Frequency or camshaft sygnal is too high. - Stored
3. P1354 (-002) Syncronization between cranckshaft and camshaft. No crankshaft signal - Stored
4. P1354 (-002) Syncronization between cranckshaft and camshaft. No camshaft signal - Stored

I removed the camshat senzor and it seems to be ok, it is very clean (doesn`t have any iron particles on it). I even changed the temperature sensor with a new one.
I checked the crankshaft sensor too and it seems to work. It measures the r.p.m. `s when the car doesn`t want to start.

I don`t understand why the engine is going very good until it reaches 80 degrees and after this it`s like someone is coming and it`s throwing punches to the engine and he is starting going dizzy.

Please help and telp me what parts i need to change!
Thank you very much!
 

Xtractorfan

Senior Member
Joined
Nov 16, 2007
Messages
6,084
Reaction score
156
Your Mercedes
S class
I would be inclined to change the CPS as when you tested it it may have given a reading.. also possible that the Air flow meter MAF needs replacing..
 
OP
V

victor_X

New Member
Joined
Jun 18, 2009
Messages
4
Reaction score
0
  • Thread Starter
  • Thread starter
  • #3
I would be inclined to change the CPS as when you tested it it may have given a reading.. also possible that the Air flow meter MAF needs replacing..

I will try to change the CPS and i guess i need the original sensor. Do you have an idea what is the price for this sensor?
If the problem will persist i will change the MAF as well!
Thank you very much for your suggestions!
 
OP
V

victor_X

New Member
Joined
Jun 18, 2009
Messages
4
Reaction score
0
  • Thread Starter
  • Thread starter
  • #4
Hello! it`s me again

I noticed a new thing about my car and i`m not sure yet if i need to buy the CPS!
I studied my car today very closely and i noticed that it not overcomes 3000 laps and does not start exactly when the temperature is in the interval of 80 and 90 degrees. Before 80 degrees and after 90 degrees it runs normal and i`m quite satisfied with it. I understand if the CPS is broken it does not function at high temperatures. But in my case, if it is the one responsible for the mallfunctions of my car, i don`t understand why it functions normal after 90 degrees.
If it`s not the cps what could be ???
I mentioned in my anterior post that i had an error P1644 Electric heater open. I checked the options of the car and i noticed that it was set on automatic and now i set if off. Could it be the heater booster linked to the major problem ?
 
OP
V

victor_X

New Member
Joined
Jun 18, 2009
Messages
4
Reaction score
0
  • Thread Starter
  • Thread starter
  • #5
Hello again!
I fixed my car!
It was the cam sensor that needed to be replaced and the egr valve that was making black smoke!
Thanks a lot for suggestions, but now i have only one error left P1664 - Heater booster circuit open and i don't now how to fix it.
 

Use the code MERCEDES and get 10% MBO Club Discount, oilman's website:www.opieoils.co.uk

register for news and offers email:sales@opieoils.co.ukphone: 01209 202944
Top Bottom