CLK 320 auto/1999 V elegance

missjt

Member
Joined
Feb 18, 2009
Messages
19
Reaction score
0
CLK 320 auto/1999 V elegance losing power/gears

Have recently had service done also MAF sensor changed due to engine cutting out.The prob now is that it seems the engine is "missing?"and not finding correct gear car also judders when waiting in traffic lights,zebra crossings etc also lost power a couple of times aswell must point out that car can do this, then we park it up and next time we drive it can appear fine any suggestions?Could it just be ATF or more serious
 
Last edited:

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
To me it sounds like that the MAF has failed, was it doing this before the new one was fitted
 
OP
M

missjt

Member
Joined
Feb 18, 2009
Messages
19
Reaction score
0
  • Thread Starter
  • Thread starter
  • #3
no the engine just cut out so we had new bosch maf sensor fitted now engine doesnt cut out just judders and loses power but not all of the time ie we live in bridport drove to weymouth car absolutely fine came home 2hrs later car was really shaking when driving slowly and really shaking when at roundabouts etc also had little power over abbots bury hill, partner said it sounded like engine was "missing" whatever that means and have been advised not to drive till been looked at.when it was serviced the gear oil was not changed and is being done this week as mechanic needed advice on how to do it.
 
OP
M

missjt

Member
Joined
Feb 18, 2009
Messages
19
Reaction score
0
  • Thread Starter
  • Thread starter
  • #4
no the engine just cut out so we had new bosch maf sensor fitted now engine doesnt cut out just judders and loses power but not all of the time ie we live in bridport drove to weymouth car absolutely fine came home 2hrs later car was really shaking when driving slowly and really shaking when at roundabouts etc also had little power over abbots bury hill, partner said it sounded like engine was "missing" whatever that means and have been advised not to drive till been looked at.when it was serviced the gear oil was not changed and is being done this week as mechanic needed advice on how to do it.
 

Uncle Benz

Senior Member
Joined
Mar 31, 2006
Messages
3,457
Reaction score
2,112
Age
50
Location
West Sussex
Your Mercedes
Mainly Mercedes
Sounds to me like you have a cylinder cut due to misfiring. Does it run OK for a bit if you switch it off and start again??

You really need to get the car to a specialist, as it sounds like the mechanic you have may be out of his depth...
 
OP
M

missjt

Member
Joined
Feb 18, 2009
Messages
19
Reaction score
0
  • Thread Starter
  • Thread starter
  • #6
please can you tell me what i should be expecting to pay for cylinder cut out
 
OP
M

missjt

Member
Joined
Feb 18, 2009
Messages
19
Reaction score
0
  • Thread Starter
  • Thread starter
  • #7
Sounds to me like you have a cylinder cut due to misfiring. Does it run OK for a bit if you switch it off and start again??

You really need to get the car to a specialist, as it sounds like the mechanic you have may be out of his depth...

yes thats exactly right what should i be looking at costs wise if this is the case?
 


The SL SHOP YOUR ONE STOP SHOP FOR ALL THINGS SL, SERVICE & RESTORE, SALES, HIRE & PARTS
Choose from a wide range of superbly prepared SL’s each with a 12 month guarantee. We can service, update, re-trim, restore and repaint your 107 SL.
Choose from a 6 or 8 cylinder car for the day, the weekend, a month or a year. Contact us for a wide range of parts. Tel: 0844 414 2116 or visit our website atwww.theSLshop.com
Top Bottom